Variables epicly failed

Started by Ronnon on Sun, 07/12/2015 - 23:49

Topic category: Help with MCreator modding

Last seen on 02:11, 14. Jul 2015
Joined Jul 2015
User points:


  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Variables epicly failed
Sun, 07/12/2015 - 23:49

I spent the last 2 days making this amazing minigame based on variables.

Basically an object right-clicked on, would open a GUI with dice and a roll button, a continue button, your total score, your opponents score, and some variables preventing you from re-clicking anything until the game was over.

It all worked great in the test environment, I'd use the table, it took the currency like I wanted it to, then it would open my game GUI, you'd roll your dice, choose which ones to keep, press to continue, it would compare your score to opponent score, then either send you to a win or lose GUI and reward you if you won.

When I tried to compile it however, it said every single variable I made had a "missing symbol"

This led me to wipe everything and try and make a simple GUI with ANY variable attached to it, guess what? can't compile, In otner words, the entire variable system for mcreator is useless. Or am I using it wrong?

I checked everything twice, and as I said, even the most basic of GUI's using a variable renders it unable to compile.