MCreator On Mac [Problem]

Started by Stijn on Wed, 08/12/2015 - 12:14
Last seen on 09:54, 13. Aug 2015
Joined Aug 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MCreator On Mac [Problem]
Wed, 08/12/2015 - 12:14

Hello,

I am a mod maker on a mac but the problem is, when i click start client (to test the mod) it wont start

 

I hope you can fix this.

Thanks, Stijn

Last seen on 22:30, 17. Jan 2016
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
This is a common problem,
Wed, 08/12/2015 - 22:51

This is a common problem, with multiple posts, but no one has answered. if you are looking for an answer soon, it will not come.

signed,

The guy who has also had this problem

Last seen on 05:09, 15. Aug 2015
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:This is a common problem,
Sat, 08/15/2015 - 03:20

I third this comment ....

BOOTING UP GRADLE...
Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 14 milliseconds]
RIGHT click once to copy log to the clipboard or twice to clear the log.
===================================================================================================================================
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
sudo: no tty present and no askpass program specified
Task completed with return code 1 in 373 milliseconds
===================================================================================================================================
Executing gradle command: clean build
sudo: no tty present and no askpass program specified
Task completed with return code 1 in 154 milliseconds
===================================================================================================================================
Executing gradle command: clean build
sudo: no tty present and no askpass program specified

Last seen on 00:41, 18. Aug 2015
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:RE:This is a common problem,
Sat, 08/15/2015 - 19:52

That is what's happening to me and even though I've looked everywhere, I can't find a solution! Please help!!

 

Last seen on 20:17, 29. Aug 2018
Joined Apr 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
probably not your macs fault
Sat, 08/15/2015 - 23:33

probably not your macs fault i use windows and the same thing happens i just upgrade to the next mcreator if there is a next one

 

Last seen on 22:30, 17. Jan 2016
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
i use the latest, v1.5.7
Tue, 08/18/2015 - 23:55

i use the latest, v1.5.7

Last seen on 23:16, 27. Dec 2015
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
This thing sucks, man. You
Fri, 08/21/2015 - 18:11

This thing sucks, man. You get all excited because you made an amazing mod, but then you cannot export or even test it. I also have this problem. I agree with above: let's just wait until the new version comes out if there is any

Last seen on 17:02, 29. Dec 2017
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Yeah, this happens to me too
Fri, 08/21/2015 - 19:03

Yeah, this happens to me too :(

Last seen on 17:46, 19. Nov 2015
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I had the same issue on a mac
Sun, 11/15/2015 - 22:32

I had the same issue on a mac. It basically means the program doesn't have admin permission to run. I fixed this by opening the .jar in a terminal command (Im sure there is an equivalent fix for PC)

1. Open terminal

2. type in "cd [your MCreator directory]" You can just type in cd, space, and click and drag your MCreator folder into the terminal, it will autofill.

3. type in "sudo java -jar MCreator.jar"

4. It will ask for a password. this is your computer admin password. it will look like you aren't typing anything, don't worry that is normal. Just enter password, hit enter, should solve your problem.

This basically runs the program in admin mode. You may have to do this every time you run the program. I hope this helps.

Last seen on 11:21, 21. Nov 2015
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Because Mac Sucks
Tue, 11/17/2015 - 09:19

Because Mac Sucks

Last seen on 00:38, 8. May 2017
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Try typing in this gradle
Wed, 11/18/2015 - 02:36

Try typing in this gradle command:

clean runClient

Or factory reset MCreator.