Custom AI Broken!

Started by TheComicCrafter on Fri, 09/04/2015 - 02:32
Last seen on 01:02, 11. May 2017
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Custom AI Broken!
Fri, 09/04/2015 - 02:32

I recently made a Sinestro boss mob mod, and wanted to give it custom AI. I added an AI task to act aggresively against Players with a priority of 10, and an AI task to act aggresively against Villagers with a priority of 5, as well as an AI task to wander. However, every time I spawn the mob, it wanders around, but doesn't attack the villagers I spawn and won't attack me in survival mode. Also, when it dies, it is supposed to say "No one... defeats... the might of... Sinestro..." but it just dies and does nothing.

Last seen on 23:49, 11. Jan 2016
Joined Jul 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I've found that the act
Fri, 09/04/2015 - 05:43

I've found that the act agressively against something AI task doesn't work on its own. However I have be able to make it work by adding the attack on colide task for the same entity. When I have both of those it works for me. As for the displaying of messages... I  just have never been able to get it to work.

Last seen on 01:02, 11. May 2017
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:I've found that the act
Fri, 09/04/2015 - 18:19

@#1 Thanks, I'll try the attack thing as a temporary fix until the next update.

Last seen on 01:10, 12. Aug 2018
Joined Feb 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Thank you Lenare :)!!! But
Sat, 08/13/2016 - 15:26

Thank you Lenare :)!!! But now I have An Ore Boss chasing me around and its almost as fast as me. :) thx!