"Cannot find symbol"

Started by SnazzyPine25 on Wed, 12/16/2015 - 22:26
Last seen on 03:14, 4. Jan 2016
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
"Cannot find symbol"
Wed, 12/16/2015 - 22:26

While trying to use a command on a food, "On item creation" I tried to make it so the player gets a bucket back.

When building i came upon this error.

All copied and pasted from console.

Executing gradle command: clean build
Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.
C:\Pylo\MCreatorV1.8>cd forge
C:\Pylo\MCreatorV1.8\forge>SET "JAVA_HOME=C:\Pylo\MCreatorV1.8\jdk\"
C:\Pylo\MCreatorV1.8\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreatorV1.8\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreatorV1.8\forge>SET "JAVA_OPTS=-Xmx256m -Xms200m"
C:\Pylo\MCreatorV1.8\forge>gradlew clean build
****************************
 Powered By MCP:             
 http://modcoderpack.com/    
 Searge, ProfMobius, Fesh0r, 
 R4wk, ZeuX, IngisKahn, bspkrs
 MCP Data version : snapshot_20141130
****************************
:clean
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
C:\Pylo\MCreatorV1.8\forge\build\sources\java\mod\mcreator\mcreator_cheese.java:125: error: cannot find symbol
int j = (int)(entity.prevPosY + (entity.posY - entity.prevPosY) * (double)var4 + 1.62D - (double)entity.yOffset);
                                                                                                       ^
  symbol:   variable yOffset
  location: variable entity of type EntityPlayer
1 error
:compileJava FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
BUILD FAILED
Total time: 15.941 secs
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
C:\Pylo\MCreatorV1.8\forge>
Task completed with return code 0 in 16964 milliseconds
   
Executing gradle command: clean build
Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.
C:\Pylo\MCreatorV1.8>cd forge
C:\Pylo\MCreatorV1.8\forge>SET "JAVA_HOME=C:\Pylo\MCreatorV1.8\jdk\"
C:\Pylo\MCreatorV1.8\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreatorV1.8\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreatorV1.8\forge>SET "JAVA_OPTS=-Xmx256m -Xms200m"
C:\Pylo\MCreatorV1.8\forge>gradlew clean build
****************************
 Powered By MCP:             
 http://modcoderpack.com/    
 Searge, ProfMobius, Fesh0r, 
 R4wk, ZeuX, IngisKahn, bspkrs
 MCP Data version : snapshot_20141130
****************************
:clean
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
:compileJava
:processResources
:classes
:jar
:compileTestJava UP-TO-DATE
:processTestResources UP-TO-DATE
:testClasses UP-TO-DATE
:test UP-TO-DATE
:extractMcpData UP-TO-DATE
:getVersionJson
:extractUserDev UP-TO-DATE
:genSrgs SKIPPED
:reobf
:assemble
:check UP-TO-DATE
:build
BUILD SUCCESSFUL
Total time: 27.992 secs
C:\Pylo\MCreatorV1.8\forge>
Task completed with return code 0 in 29117 milliseconds
Task return code check OK!
Last seen on 02:00, 29. Jun 2016
Joined Jul 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I know this is old but im
Sun, 04/24/2016 - 20:25

I know this is old but im having the same problem does anyone have a fix?

Last seen on 20:11, 2. Jul 2016
Joined Sep 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
it is just an bug, recompile
Sun, 04/24/2016 - 22:29

it is just an bug, recompile and will be fine

Last seen on 16:05, 4. Aug 2018
Joined Nov 2013
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
entity.yOffset should
Mon, 04/25/2016 - 04:51

entity.yOffset should actually be entity.getYOffset, you'll have to edit the source code.

Last seen on 18:32, 28. May 2018
Joined Jul 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
If you use a (filled) bucket
Mon, 04/25/2016 - 08:10

If you use a (filled) bucket in a recipe you will always get an empty bucket back.