Techne mob error!

Started by saajsterxpro on Wed, 12/23/2015 - 22:11
Last seen on 16:50, 25. Aug 2016
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Techne mob error!
Wed, 12/23/2015 - 22:11

Yo, I have been working on a Techne mob four hours and I follow the mcreator tutorial for exporting & importing textures ect. However, I get an error at recompiling?!

 

Steps of what I done:

Made Techne mob

Made Texture

Put together, exported as .java file

Imported to Mcreator

Recompile... I get this error:

http://pastebin.com/QMDvHdja

 

Help me if you can, thanks! Will be submitting my mod after this bug is fixed :D

Last seen on 16:50, 25. Aug 2016
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Nevermind I fixed it! It was
Wed, 12/23/2015 - 22:29

Nevermind I fixed it! It was complaining that the Techne model's name had a space in it.

DO NOT PUT SPACES IN YOUR TECHNE MODEL NAME! :)

Hope this helps anyone!

Last seen on 16:50, 25. Aug 2016
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Ah why isn't the mob moving
Wed, 12/23/2015 - 22:39

Ah why isn't the mob moving or attacking?!

Last seen on 22:33, 5. Aug 2017
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
To make it attack you must
Thu, 12/24/2015 - 08:21

To make it attack you must set it to "mob" not creature, not ambient

Also it may not move if you selected the AI to none and didn't add any tasks

Last seen on 16:50, 25. Aug 2016
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:To make it attack you must
Thu, 12/24/2015 - 11:44

@#3 Thank you for your reply, the problem was because either my mob moves sideways for some reason XD or because i needed to select an AI and add tasks manually :)

- Thanks