MCreator 1.5.9 server is BROKEN!

Started by Baddog999 on Wed, 02/10/2016 - 22:24

Topic category: Help with MCreator modding

Last seen on 02:37, 9. Apr 2017
Joined Jun 2013
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MCreator 1.5.9 server is BROKEN!
Mon, 02/15/2016 - 19:08 (edited)

Me and my friends are creating a modpack, and i am attempting to add my mod to the server. However, when launching the server with my mod, I come across this error and can not figure out how to fix it. I have found that the problem is definitely my mod, and not a compatibility issue (the server also crashes with only my mod on it and has the same error). Here is the crash report. Help appreciated.

 

UPDATE:

I figured out this has nothing to do with my mod, and the problem is that MCreator 1.5.9 mods just break servers in general. I tested this by making a block in an empty workspace and running the server. This crashed it and gave me the same error. If someone could check this and figure out whether it is a problem with my computer or with MCreator that would be helpful. Thanks.

Edited by Baddog999 on Mon, 02/15/2016 - 19:08
Last seen on 23:46, 10. May 2017
Joined Feb 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I too would like to know how
Mon, 02/15/2016 - 19:23

I too would like to know how to make multiplayer mods, its been driving me up the wall, I am grateful that this creation kit even exists, but would really like some genuine help on creating multiplayer server mods.

Last seen on 02:37, 9. Apr 2017
Joined Jun 2013
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I have somewhat gotten
Wed, 02/17/2016 - 03:22

I have somewhat gotten through it. I used the crappy method of removing all blocks from the mod, since the blocks are the problem.