MCskin3D not working

Started by Cartrr215 on Fri, 02/26/2016 - 01:55
Last seen on 23:30, 23. Jan 2017
Joined May 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MCskin3D not working
Fri, 02/26/2016 - 01:55

When I try to launch MCskin3D it says it has "become unstable" and gives me this error report:

OpenGL
--------------------------------
OpenGL: Intel 4.0.0 - Build 10.18.10.4061 Intel(R) HD Graphics 4000

Software
--------------------------------
OS: Microsoft Windows NT 6.1.7601 Service Pack 1 x64
.NET Version: 4.0.30319.34209
MCSkin3D Version: 1.5.0.402

Exception
--------------------------------
System.Exception
Failed to initialize program during "Initializing base forms..."
No Stack Trace Available
System.IO.DirectoryNotFoundException
Could not find a part of the path 'C:\Users\Carter\Desktop\external\mcskin3d\Overlays'.
 System.Windows.Forms.Control :: System.Object MarshaledInvoke(System.Windows.Forms.Control, System.Delegate, System.Object[], Boolean)
 System.Windows.Forms.Control :: System.Object Invoke(System.Delegate, System.Object[])
 System.Windows.Forms.Control :: System.Object Invoke(System.Delegate)
 MCSkin3D.Forms.Splash :: Void PerformLoading()
  - C:\Users\Paril\Documents\GitHub\mcskin3d\Splash\Splash.cs 90:5

 

 

 

 

Anyone know what's going on and how to fix it? Please help me!

 

Last seen on 13:27, 22. Apr 2017
Joined Jun 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Hey there,
Sat, 02/27/2016 - 17:16

Hey there,

I believe the version attached to Mcreator at the moment is the unstable part.

You might have better luck actually getting a stable version of MCskin3D from the developer here;

http://www.planetminecraft.com/mod/mcskin3d/

I hope that works out for you.

Regards,

DD

Last seen on 23:30, 23. Jan 2017
Joined May 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Hey there,
Sun, 02/28/2016 - 00:36

@#1 

I tried to run it after downloading it from there: it opens, but I can't figure out how to import a techne model- also when I tried pressing one of the buttons in the toolbar, it gave me this error:

OpenGL
--------------------------------
OpenGL: Intel 4.0.0 - Build 10.18.10.4061 Intel(R) HD Graphics 4000

Software
--------------------------------
OS: Microsoft Windows NT 6.1.7601 Service Pack 1 x64
.NET Version: 4.0.30319.34209
MCSkin3D Version: 1.5.0.402

Exception
--------------------------------
System.NullReferenceException
Object reference not set to an instance of an object.
 MCSkin3D.Editor :: Void ToggleVisiblePart(MCSkin3D.ModelPart)
  - C:\Users\Paril\Documents\GitHub\mcskin3d\Forms\Editor.cs 3712:4
 MCSkin3D.Editor :: Void toggleHeadToolStripButton_Click(System.Object, System.EventArgs)
  - C:\Users\Paril\Documents\GitHub\mcskin3d\Forms\Editor.cs 2037:4
 System.Windows.Forms.ToolStripItem :: Void RaiseEvent(System.Object, System.EventArgs)
 System.Windows.Forms.ToolStripButton :: Void OnClick(System.EventArgs)
 System.Windows.Forms.ToolStripItem :: Void HandleClick(System.EventArgs)
 System.Windows.Forms.ToolStripItem :: Void HandleMouseUp(System.Windows.Forms.MouseEventArgs)
 System.Windows.Forms.ToolStripItem :: Void FireEventInteractive(System.EventArgs, System.Windows.Forms.ToolStripItemEventType)
 System.Windows.Forms.ToolStripItem :: Void FireEvent(System.EventArgs, System.Windows.Forms.ToolStripItemEventType)
 System.Windows.Forms.ToolStrip :: Void OnMouseUp(System.Windows.Forms.MouseEventArgs)
 System.Windows.Forms.Control :: Void WmMouseUp(System.Windows.Forms.Message ByRef, System.Windows.Forms.MouseButtons, Int32)
 System.Windows.Forms.Control :: Void WndProc(System.Windows.Forms.Message ByRef)
 System.Windows.Forms.ScrollableControl :: Void WndProc(System.Windows.Forms.Message ByRef)
 System.Windows.Forms.ToolStrip :: Void WndProc(System.Windows.Forms.Message ByRef)
 System.Windows.Forms.Control+ControlNativeWindow :: Void OnMessage(System.Windows.Forms.Message ByRef)
 System.Windows.Forms.Control+ControlNativeWindow :: Void WndProc(System.Windows.Forms.Message ByRef)
 System.Windows.Forms.NativeWindow :: IntPtr Callback(IntPtr, Int32, IntPtr, IntPtr)

 

 

 

Is it just because I haven't imported a texture file yet?

Last seen on 13:27, 22. Apr 2017
Joined Jun 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Firstly, what button did you
Sun, 02/28/2016 - 15:04

Firstly, what button did you press?

Secondly where are you trying to import the techne model to?