How to fix a crash?

Started by Minecrafter7215 on Sun, 04/10/2016 - 20:15

Topic category: Help with MCreator modding

Last seen on 00:56, 5. May 2016
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
How to fix a crash?
Sun, 04/10/2016 - 20:15

Can somebody tell me how to fix this crash?

 

---- Minecraft Crash Report ----
// You're mean.

Time: 10/04/16 1:09 PM
Description: Ticking entity

java.lang.NullPointerException: Ticking entity
    at net.minecraft.item.ItemStack.func_111283_C(ItemStack.java:745)
    at net.minecraft.entity.EntityLivingBase.func_70071_h_(EntityLivingBase.java:1598)
    at net.minecraft.entity.EntityLiving.func_70071_h_(EntityLiving.java:206)
    at net.minecraft.entity.monster.EntityMob.func_70071_h_(SourceFile:30)
    at net.minecraft.world.World.func_72866_a(World.java:2070)
    at net.minecraft.world.WorldServer.func_72866_a(WorldServer.java:648)
    at net.minecraft.world.World.func_72870_g(World.java:2034)
    at net.minecraft.world.World.func_72939_s(World.java:1887)
    at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:489)
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:636)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:111)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at net.minecraft.item.ItemStack.func_111283_C(ItemStack.java:745)
    at net.minecraft.entity.EntityLivingBase.func_70071_h_(EntityLivingBase.java:1598)
    at net.minecraft.entity.EntityLiving.func_70071_h_(EntityLiving.java:206)
    at net.minecraft.entity.monster.EntityMob.func_70071_h_(SourceFile:30)
    at net.minecraft.world.World.func_72866_a(World.java:2070)
    at net.minecraft.world.WorldServer.func_72866_a(WorldServer.java:648)
    at net.minecraft.world.World.func_72870_g(World.java:2034)

-- Entity being ticked --
Details:
    Entity Type: mob (mod.mcreator.mcreator_mob.Entitymob)
    Entity ID: 564985
    Entity Name: Evil Emerald Person
    Entity's Exact location: -1192.50, 90.00, 179.50
    Entity's Block location: World: (-1193,90,179), Chunk: (at 7,5,3 in -75,11; contains blocks -1200,0,176 to -1185,255,191), Region: (-3,0; contains chunks -96,0 to -65,31, blocks -1536,0,0 to -1025,255,511)
    Entity's Momentum: 0.00, 0.00, 0.00
Stacktrace:
    at net.minecraft.world.World.func_72939_s(World.java:1887)
    at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:489)

-- Affected level --
Details:
    Level name: TESTING
    All players: 1 total; [EntityPlayerMP['Minecrafter7215'/0, l='TESTING', x=-1209.00, y=46.00, z=253.00]]
    Chunk stats: ServerChunkCache: 675 Drop: 0
    Level seed: 632165226425281326
    Level generator: ID 00 - default, ver 1. Features enabled: false
    Level generator options:
    Level spawn location: World: (0,0,0), Chunk: (at 0,0,0 in 0,0; contains blocks 0,0,0 to 15,255,15), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
    Level time: 0 game time, 0 day time
    Level dimension: 0
    Level storage version: 0x00000 - Unknown?
    Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
    Level game mode: ~~ERROR~~ NullPointerException: null
Stacktrace:
    at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:636)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:111)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

-- System Details --
Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 75812120 bytes (72 MB) / 321482752 bytes (306 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 4 mods loaded, 4 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJAAAA    mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJAAAA    FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UCHIJAAAA    Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar)
    UCHIJAAAA    EmeraldCraft{1.0.3} [EmeraldCraft] (EmeraldCraft_v1.0.3_1.7.10.jar)
    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Player Count: 1 / 8; [EntityPlayerMP['Minecrafter7215'/0, l='TESTING', x=-1209.00, y=46.00, z=253.00]]
    Type: Integrated Server (map_client.txt)
    Is Modded: Definitely; Client brand changed to 'fml,forge'

Last seen on 22:33, 5. Aug 2017
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Yeah, I have this problem too
Mon, 04/11/2016 - 06:27

Yeah, I have this problem too. Did you set a mob spawning to 0?

Last seen on 00:56, 5. May 2016
Joined Sep 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:Yeah, I have this problem too
Sat, 04/16/2016 - 17:42

@#1

I figured out what was causing this probelm. On my first update, I put a helmet on my custom mob's head. But the helmet was covering the mob's eyes, so I wanted to take the helmet off. But there wasn't a "take off" option so I replaced the helmet with "air". So I had to delete the mob and make it again.