My Dimension won't work

Started by EditName on Mon, 07/31/2017 - 12:40

Topic category: Help with MCreator's application

Last seen on 14:07, 28. Oct 2017
Joined Jul 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
My Dimension won't work
Mon, 07/31/2017 - 12:40

So I was working on creating my second Dimension but when I test out the mod the portal works fine but it shows the purple and black error block for the custom lighter and the middle of the portal. Any ideas why? I made sure each image was 16x16 and png.

 

   
Executing gradle command: runClient
Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.
C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit>cd forge
C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge>SET "JAVA_HOME=C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\jdk32\"
C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge>gradlew -Dorg.gradle.jvmargs="-Xms512m -Xmx1024m" runClient
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: http://gradle.org/docs/2.0/userguide/gradle_daemon.html.
****************************
 Powered By MCP:             
 http://modcoderpack.com/    
 Searge, ProfMobius, Fesh0r, 
 R4wk, ZeuX, IngisKahn, bspkrs
 MCP Data version : unknown
****************************
:downloadClient SKIPPED
:downloadServer SKIPPED
:getVersionJson
:extractUserDev UP-TO-DATE
:mergeJars SKIPPED
:applyBinPatches SKIPPED
:downloadMcpTools SKIPPED
:extractMcpData UP-TO-DATE
:genSrgs SKIPPED
:deobfBinJar SKIPPED
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava UP-TO-DATE
:compileJava
:processResources UP-TO-DATE
:classes
:jar UP-TO-DATE
:extractNatives UP-TO-DATE
:getAssetsIndex
:getAssets
:makeStart
[ant:javac] warning: [options] bootstrap class path not set in conjunction with -source 1.6
[ant:javac] 1 warning
:runClient
[08:40:09] [main/INFO]: Extra: []
[08:40:09] [main/INFO]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/RAC/.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --accessToken, {REDACTED}, --version, 1.7.10, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[08:40:09] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[08:40:09] [main/INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
[08:40:09] [main/INFO]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[08:40:09] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
[08:40:09] [main/INFO]: Forge Mod Loader version 7.99.36.1558 for Minecraft 1.7.10 loading
[08:40:09] [main/INFO]: Java is Java HotSpot(TM) Client VM, version 1.8.0_101, running on Windows 10:x86:10.0, installed at C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\jdk32\jre
[08:40:09] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[08:40:09] [main/INFO]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[08:40:09] [main/INFO]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
[08:40:09] [main/INFO]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[08:40:09] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[08:40:09] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
[08:40:09] [main/INFO]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[08:40:09] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[08:40:09] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
[08:40:09] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[08:40:10] [main/ERROR]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
[08:40:11] [main/ERROR]: FML appears to be missing any signature data. This is not a good thing
[08:40:11] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
[08:40:11] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
[08:40:11] [main/INFO]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[08:40:11] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
[08:40:11] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
[08:40:11] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[08:40:12] [main/INFO]: Setting user: Player232
[08:40:14] [Client thread/INFO]: LWJGL Version: 2.9.1
[08:40:15] [Client thread/INFO]: [cpw.mods.fml.client.SplashProgress:start:188
// I just don't know what went wrong :(
Time: 7/31/17 8:40 AM
Description: Loading screen debug info
This is just a prompt for computer specs to be printed. THIS IS NOT A ERROR
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
   Minecraft Version: 1.7.10
   Operating System: Windows 10 (x86) version 10.0
   Java Version: 1.8.0_101, Oracle Corporation
   Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
   Memory: 19430728 bytes (18 MB) / 48046080 bytes (45 MB) up to 259522560 bytes (247 MB)
   JVM Flags: 0 total; 
   AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: 
   GL info: ' Vendor: 'Intel' Version: '4.4.0 - Build 21.20.16.4550' Renderer: 'Intel(R) HD Graphics 610'
[08:40:15] [Client thread/INFO]: Attempting early MinecraftForge initialization
[08:40:15] [Client thread/INFO]: MinecraftForge v10.13.4.1558 Initialized
[08:40:15] [Client thread/INFO]: Replaced 183 ore recipies
[08:40:15] [Client thread/INFO]: Completed early MinecraftForge initialization
[08:40:15] [Client thread/INFO]: Found 0 mods from the command line. Injecting into mod discoverer
[08:40:15] [Client thread/INFO]: Searching C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\eclipse\mods for mods
[08:40:26] [Client thread/INFO]: Mod TestEnvironmentMod is missing the required element 'name'. Substituting TestEnvironmentMod
[08:40:26] [Client thread/INFO]: Forge Mod Loader has identified 4 mods to load
[08:40:26] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, TestEnvironmentMod] at CLIENT
[08:40:26] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, TestEnvironmentMod] at SERVER
[08:40:27] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:TestEnvironmentMod
[08:40:27] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:27] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:27] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:27] [Client thread/INFO]: Processing ObjectHolder annotations
[08:40:27] [Client thread/INFO]: Found 341 ObjectHolder annotations
[08:40:27] [Client thread/INFO]: Identifying ItemStackHolder annotations
[08:40:27] [Client thread/INFO]: Found 0 ItemStackHolder annotations
[08:40:27] [Client thread/INFO]: Configured a dormant chunk cache size of 0
[08:40:27] [Client thread/INFO]: Applying holder lookups
[08:40:27] [Client thread/INFO]: Holder lookups applied
[08:40:27] [Client thread/INFO]: Injecting itemstacks
[08:40:27] [Client thread/INFO]: Itemstack injection complete
[08:40:27] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:27] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:27] [Thread-8/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:27] [Thread-8/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:27] [Thread-8/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:28] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:28] [Sound Library Loader/INFO]: Sound engine started
[08:40:29] [Client thread/INFO]: Created: 16x16 textures/blocks-atlas
[08:40:29] [Client thread/INFO]: Created: 16x16 textures/items-atlas
[08:40:29] [Client thread/WARN]: ****************************************
[08:40:29] [Client thread/WARN]: * The object mod.mcreator.mcreator_zipADeeWorld$BlockTutorialPortal@c234f8 has been registered twice for the same name TestEnvironmentMod:zipADeeWorld_portal.
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.FMLControlledNamespacedRegistry.add(FMLControlledNamespacedRegistry.java:384)
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.GameData.registerBlock(GameData.java:894)
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.GameData.registerBlock(GameData.java:869)
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:229)
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:188)
[08:40:29] [Client thread/WARN]: *  at cpw.mods.fml.common.registry.GameRegistry.registerBlock(GameRegistry.java:177)...
[08:40:29] [Client thread/WARN]: ****************************************
[08:40:29] [Client thread/INFO]: Injecting itemstacks
[08:40:29] [Client thread/INFO]: Itemstack injection complete
[08:40:29] [Client thread/INFO]: Forge Mod Loader has successfully loaded 4 mods
[08:40:29] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:TestEnvironmentMod
[08:40:29] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:29] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:29] [Client thread/WARN]: ResourcePack: ignored non-lowercase namespace: TestEnvironmentMod in C:\Users\RAC\Downloads\MCreator 1.7.2 [1.7.10] Windows 32bit\forge\build\libs\modid-1.0.jar
[08:40:29] [Client thread/INFO]: Created: 512x256 textures/blocks-atlas
[08:40:30] [Client thread/INFO]: Created: 256x256 textures/items-atlas
[08:40:30] [Client thread/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Client thread/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Client thread/INFO]: [paulscode.sound.SoundSystemLogger:importantMessage:90
[08:40:30] [Client thread/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Thread-10/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Thread-10/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Thread-10/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Sound Library Loader/INFO]: [paulscode.sound.SoundSystemLogger:message:69
[08:40:30] [Sound Library Loader/INFO]: Sound engine started
[08:40:31] [Client thread/ERROR]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[08:40:31] [Client thread/ERROR]: The following texture errors were found.
[08:40:31] [Client thread/ERROR]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
[08:40:48] [Server thread/INFO]: Starting integrated minecraft server version 1.7.10
[08:40:48] [Server thread/INFO]: Generating keypair
[08:40:48] [Server thread/INFO]: Injecting existing block and item data into this server instance
[08:40:48] [Server thread/INFO]: Applying holder lookups
[08:40:48] [Server thread/INFO]: Holder lookups applied
[08:40:49] [Server thread/INFO]: Loading dimension 0 (test Mod) (net.minecraft.server.integrated.IntegratedServer@f983fc)
[08:40:49] [Server thread/INFO]: Loading dimension 7 (test Mod) (net.minecraft.server.integrated.IntegratedServer@f983fc)
[08:40:49] [Server thread/INFO]: Loading dimension 1 (test Mod) (net.minecraft.server.integrated.IntegratedServer@f983fc)
[08:40:49] [Server thread/INFO]: Loading dimension -1 (test Mod) (net.minecraft.server.integrated.IntegratedServer@f983fc)
[08:40:49] [Server thread/INFO]: Preparing start region for level 0
[08:40:50] [Server thread/INFO]: Changing view distance to 8, from 10
[08:40:50] [Netty Client IO #0/INFO]: Server protocol version 2
[08:40:50] [Netty IO #1/INFO]: Client protocol version 2
[08:40:50] [Netty IO #1/INFO]: Client attempting to join with 4 mods : FML@7.10.99.99,Forge@10.13.4.1558,mcp@9.05,TestEnvironmentMod@1.0
[08:40:50] [Netty IO #1/INFO]: Attempting connection with missing mods [] at CLIENT
[08:40:50] [Netty Client IO #0/INFO]: Attempting connection with missing mods [] at SERVER
[08:40:50] [Server thread/INFO]: [Server thread] Server side modded connection established
[08:40:50] [Client thread/INFO]: [Client thread] Client side modded connection established
[08:40:51] [Server thread/INFO]: Player232[local:E:59dd9b5e] logged in with entity id 191 at (-414.48377833738084, 4.0, -623.4383203981687)
[08:40:51] [Server thread/INFO]: Player232 joined the game
[08:40:54] [Server thread/INFO]: Player232 has just earned the achievement [Taking Inventory]
[08:40:54] [Client thread/INFO]: [CHAT] Player232 has just earned the achievement [Taking Inventory]

Last seen on 20:03, 30. Apr 2019
Joined Jul 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I've found that this happens
Mon, 07/31/2017 - 16:41

I've found that this happens sometimes when I spawn an item in with a command, just in general/vanilla Minecraft. I'd recommend you make sure that the portal igniter is created within the dimension modification (2x click on the dimension to edit it, then find the igniter). Also if you have any animated textures make sure they are the right size or try static textures altogether.

Last seen on 14:07, 28. Oct 2017
Joined Jul 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Not sure what you mean by " I
Tue, 08/01/2017 - 00:30

Not sure what you mean by " I'd recommend you make sure that the portal igniter is created within the dimension modification (2x click on the dimension to edit it, then find the igniter)"

Also I am not using any animated textures.