Dimension Bug or error on my side?

Started by revmykl777 on Fri, 05/09/2014 - 23:03

Topic category: Help with MCreator modding

Last seen on 21:28, 14. Oct 2019
Joined Oct 2013
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Dimension Bug or error on my side?
Fri, 05/09/2014 - 23:03

So anytime I create a Dimension I get a completely dark dimension. I've tried with custom Biomes and Default biomes, always pitch dark. Tried with and without the "Has Dusk/Dawn" button clicked. Is anyone else having this issue?

Last seen on 23:25, 4. Jun 2014
Joined Mar 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I believe its a bug, unless
Sun, 05/11/2014 - 22:29

I believe its a bug, unless its some complicated process thing, then its a bug.

Last seen on 21:34, 25. Apr 2019
Joined Jun 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
You can't do it through
Sun, 06/08/2014 - 22:02

You can't do it through MCreator, or so I've found. Not through the wizards, at any rate. You have to open up the java code (which you CAN do through MCreator) and make the following changes (the code is found a little way from the top):

public void registerWorldChunkManager(){
this.worldChunkMgr = new WorldChunkManagerHell(mcreator_deadbiome.biome, 0.0F);
this.isHellWorld = true; <<<=== This should now be False
this.hasNoSky = true; <<<=== This should now be False
this.dimensionId = DIMID;
}

Also, if you want a sun in your dimension, you have to change the following (just a bit further down on the page):

public boolean isSurfaceWorld(){
return false; <<<=== This should now be True
}

At least, that's what has worked for me...