Running Client Error - Custom mob model

Published by Malavek on Wed, 02/14/2018 - 02:31
Status
Works as designed
Type
Product/platform
Not applicable
Priority
Normal
Issue description

Executing gradle command: clean runClient
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
C:\Users\Malavek\Desktop\MCreator177>cd forge
C:\Users\Malavek\Desktop\MCreator177\forge>SET "JAVA_HOME=C:\Users\Malavek\Desktop\MCreator177\jdk64\"
C:\Users\Malavek\Desktop\MCreator177\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Users\Malavek\Desktop\MCreator177\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Users\Malavek\Desktop\MCreator177\forge>gradlew -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean runClient 
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
#################################################
         ForgeGradle 2.3-SNAPSHOT-e65f1e2        
  https://github.com/MinecraftForge/ForgeGradle  
#################################################
               Powered by MCP unknown               
             http://modcoderpack.com             
         by: Searge, ProfMobius, Fesh0r,         
         R4wk, ZeuX, IngisKahn, bspkrs           
#################################################
:clean
:deobfCompileDummyTask
:deobfProvidedDummyTask
:sourceApiJava
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
:compileJava
:processResources
:classes
:jar
:getVersionJson
:extractNatives SKIPPED
:extractUserdev UP-TO-DATE
:getAssetIndex UP-TO-DATE
:getAssets
Current status: 535/1283   41%
Current status: 1110/1283   86%
:makeStart
:runClient
2018-02-13 21:29:25,270 main WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
2018-02-13 21:29:25,277 main WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
[21:29:25] [main/INFO] [GradleStart]: Extra: []
[21:29:25] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/Malavek/.gradle/caches/minecraft/assets, --assetIndex, 1.12, --accessToken{REDACTED}, --version, 1.12.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[21:29:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
[21:29:25] [main/INFO] [FML]: Forge Mod Loader version 14.23.1.2555 for Minecraft 1.12.2 loading
[21:29:25] [main/INFO] [FML]: Java is OpenJDK 64-Bit Server VM, version 1.8.0_152-release, running on Windows 7:amd64:6.1, installed at C:\Users\Malavek\Desktop\MCreator177\jdk64\jre
[21:29:25] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[21:29:25] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin), we are in deobf and it's a forge core plugin
[21:29:25] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin), we are in deobf and it's a forge core plugin
[21:29:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[21:29:25] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
[21:29:25] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[21:29:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[21:29:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
2018-02-13 21:29:26,408 main WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
2018-02-13 21:29:26,828 main WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
2018-02-13 21:29:26,833 main WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream
[21:29:27] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[21:29:27] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[21:29:27] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[21:29:28] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[21:29:28] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
[21:29:28] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
[21:29:28] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[21:29:29] [main/INFO]: Setting user: Player416
[21:29:34] [main/WARN]: Skipping bad option: lastServer:
[21:29:34] [main/WARN]: Skipping bad option: streamPreferredServer:
[21:29:34] [main/INFO]: LWJGL Version: 2.9.4
[21:29:36] [main/INFO] [FML]: -- System Details --
Details:
   Minecraft Version: 1.12.2
   Operating System: Windows 7 (amd64) version 6.1
   Java Version: 1.8.0_152-release, JetBrains s.r.o
   Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), JetBrains s.r.o
   Memory: 756767976 bytes (721 MB) / 922746880 bytes (880 MB) up to 2850553856 bytes (2718 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: 
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.5.0 NVIDIA 385.69' Renderer: 'GeForce GT 730/PCIe/SSE2'
[21:29:37] [main/INFO] [FML]: MinecraftForge v14.23.1.2555 Initialized
[21:29:37] [main/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[21:29:37] [main/INFO] [FML]: Replaced 1036 ore ingredients
[21:29:37] [main/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer
[21:29:37] [main/INFO] [FML]: Searching C:\Users\Malavek\Desktop\MCreator177\forge\run\mods for mods
[21:29:38] [main/INFO] [testenvironmentmod]: Mod testenvironmentmod is missing the required element 'name'. Substituting testenvironmentmod
[21:29:38] [main/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
[21:29:39] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at CLIENT
[21:29:39] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at SERVER
[21:29:40] [main/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:testenvironmentmod
[21:29:40] [Thread-3/INFO] [FML]: Using alternative sync timing : 200 frames of Display.update took 1035639372 nanos
[21:29:40] [main/INFO] [FML]: Processing ObjectHolder annotations
[21:29:40] [main/INFO] [FML]: Found 1168 ObjectHolder annotations
[21:29:40] [main/INFO] [FML]: Identifying ItemStackHolder annotations
[21:29:40] [main/INFO] [FML]: Found 0 ItemStackHolder annotations
[21:29:40] [main/INFO] [FML]: Configured a dormant chunk cache size of 0
[21:29:40] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotio…
[21:29:40] [main/INFO] [FML]: OBJLoader: Domain testenvironmentmod has been added.
[21:29:40] [main/INFO] [FML]: Applying holder lookups
[21:29:40] [main/INFO] [FML]: Holder lookups applied
[21:29:40] [main/INFO] [FML]: Applying holder lookups
[21:29:40] [main/INFO] [FML]: Holder lookups applied
[21:29:40] [main/INFO] [FML]: Applying holder lookups
[21:29:40] [main/INFO] [FML]: Holder lookups applied
[21:29:40] [main/INFO] [FML]: Applying holder lookups
[21:29:40] [main/INFO] [FML]: Holder lookups applied
[21:29:40] [main/INFO] [FML]: Injecting itemstacks
[21:29:40] [main/INFO] [FML]: Itemstack injection complete
[21:29:41] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Found status: OUTDATED Target: 14.23.2.2611
[21:29:43] [Sound Library Loader/INFO]: Starting up SoundSystem...
[21:29:43] [Thread-5/INFO]: Initializing LWJGL OpenAL
[21:29:43] [Thread-5/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[21:29:44] [Thread-5/INFO]: OpenAL initialized.
[21:29:44] [Sound Library Loader/INFO]: Sound engine started
[21:29:48] [main/INFO] [FML]: Max texture size: 16384
[21:29:49] [main/INFO]: Created: 512x512 textures-atlas
[21:29:51] [main/INFO] [FML]: Applying holder lookups
[21:29:51] [main/INFO] [FML]: Holder lookups applied
[21:29:51] [main/FATAL] [FML]: Fatal errors were detected during the transition from INITIALIZATION to POSTINITIALIZATION. Loading cannot continue
[21:29:51] [main/FATAL] [FML]: 
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   | State | ID                 | Version      | Source                           | Signature |
   |:----- |:------------------ |:------------ |:-------------------------------- |:--------- |
   | UCHI  | minecraft          | 1.12.2       | minecraft.jar                    | None      |
   | UCHI  | mcp                | 9.42         | minecraft.jar                    | None      |
   | UCHI  | FML                | 8.0.99.99    | forgeSrc-1.12.2-14.23.1.2555.jar | None      |
   | UCHI  | forge              | 14.23.1.2555 | forgeSrc-1.12.2-14.23.1.2555.jar | None      |
   | UCHE  | testenvironmentmod | 1.0          | modid-1.0.jar                    | None      |
[21:29:51] [main/FATAL] [FML]: The following problems were captured during this phase
[21:29:51] [main/ERROR] [FML]: Caught exception from testenvironmentmod (java.lang.NullPointerException)
[21:29:51] [main/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:629
// Quite honestly, I wouldn't worry myself about that.
Time: 2/13/18 9:29 PM
Description: There was a severe problem during mod loading that has caused the game to fail
net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from testenvironmentmod (testenvironmentmod)
Caused by: java.lang.NullPointerException
   at mod.mcreator.mcreator_headcrab$Modelheadcrabmdl001.(mcreator_headcrab.java:228)
   at mod.mcreator.mcreator_headcrab.registerRenderers(mcreator_headcrab.java:58)
   at mod.mcreator.ClientProxyTestEnvironmentMod.registerRenderers(ClientProxyTestEnvironmentMod.java:7)
   at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:68)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:608)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
   at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
   at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
   at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
   at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
   at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
   at com.google.common.eventbus.EventBus.post(EventBus.java:217)
   at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:253)
   at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:231)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
   at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
   at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
   at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
   at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
   at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
   at com.google.common.eventbus.EventBus.post(EventBus.java:217)
   at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:148)
   at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:719)
   at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:352)
   at net.minecraft.client.Minecraft.init(Minecraft.java:581)
   at net.minecraft.client.Minecraft.run(Minecraft.java:421)
   at net.minecraft.client.main.Main.main(Main.java:118)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
   at GradleStart.main(GradleStart.java:26)
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
   Minecraft Version: 1.12.2
   Operating System: Windows 7 (amd64) version 6.1
   Java Version: 1.8.0_152-release, JetBrains s.r.o
   Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), JetBrains s.r.o
   Memory: 470600472 bytes (448 MB) / 1245708288 bytes (1188 MB) up to 2850553856 bytes (2718 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: MCP 9.42 Powered by Forge 14.23.1.2555 5 mods loaded, 5 mods active
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   | State | ID                 | Version      | Source                           | Signature |
   |:----- |:------------------ |:------------ |:-------------------------------- |:--------- |
   | UCHI  | minecraft          | 1.12.2       | minecraft.jar                    | None      |
   | UCHI  | mcp                | 9.42         | minecraft.jar                    | None      |
   | UCHI  | FML                | 8.0.99.99    | forgeSrc-1.12.2-14.23.1.2555.jar | None      |
   | UCHI  | forge              | 14.23.1.2555 | forgeSrc-1.12.2-14.23.1.2555.jar | None      |
   | UCHE  | testenvironmentmod | 1.0          | modid-1.0.jar                    | None      |
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.5.0 NVIDIA 385.69' Renderer: 'GeForce GT 730/PCIe/SSE2'
[21:29:51] [main/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:629
AL lib: (EE) alc_cleanup: 1 device not closed
FAILURE: Build failed with an eTotal time: 44.348 secs
xception.
:runCli* What went wrong:
ent FAILED
BUILD FAILED
C:\Users\Malavek\Desktop\MCreator177\forge>
Task completed with return code 0 in 45518 milliseconds
Execution failed for task ':runClient'.
> Process 'command 'C:\Users\Malavek\Desktop\MCreator177\jdk64\bin\java.exe'' finished with non-zero exit value -1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

Issue comments

Thank you for your bug report. Could you please attach the exported workspace or the source file of Headcrab mod element? I suspect the model file of the mob was not properly exported.

Here you go, I don't exactly know what might've caused the problem because I tried to leave it very simple mainly to test the model but hopefully you can figure it out. Also tell me if I exported it correctly because I haven't really used this program in about a year.

Also short question: is it possible to change my username?

Thanks.

Not to rush you, but did you start looking for the problem?

What 3D modeler did you use to create the model? The error is because the model your modeler exported is invalid. This issue is not related to MCreator, but if you provide the actual model file, I might be able to fix it manually.

This was a Techne model export error. You can fix it by editing headcrabmdl001.java before importing it. Just remove the first occurrence of leg2.mirror = true; which can be found at line 66. After you remove this line, import the model and it will work.

Alright that worked, thanks. Also off-topic question: will you ever make a discord for MCreator?



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.