Mob can not drop blocks

Published by Hakann on Sat, 02/24/2018 - 14:03
Status
Won't fix
Type
Product/platform
Not applicable
Priority
Normal
Issue description

Mob can not drop blocks (not all)! If you select item to mob's drop it is works. If you select block (VINE and NETHER_WART) to mob's drop it is not works. This bug in MCreator not in forge.

P.s. I don't use event (when mob died)

Issue comments

I have used dirt for a drop and it worked. Could you attach your workspace so I can import it and see what causes the problem you described?

I can confirm this, but it seems that this is a Minecraft Forge level bug as all other blocks seem to work. I can't help to fix this as this is not a bug on our side. I will keep you posted if the Minecraft Forge fixes this, but for now, I am closing this ticket as there is not much we can do at our side.

  protected void dropRareDrop(int par1) {
   this.dropItem(new ItemStack(Blocks.NETHER_WART).getItem(), 1); Doesn't work! (no errors)

 

    @Override
  protected Item getDropItem() {
   return new ItemStack(Blocks.NETHER_WART).getItem(); Doesn't work! (no errors)

 

I have checked and it worked for me on exported Minecraft. This is a Forge bug but not important in exported mods it works.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.