Gradle Failed: Could not determine java version from '9.0.1'

Published by Asgradeous on Fri, 04/13/2018 - 15:18
Status
Works as designed
Type
Product/platform
MCreator/macOS
Priority
Normal
Issue description

Whenever I recompile my workspace or test Minecraft client environment (to test what I have made), I always get this: (except with the Minecraft client environment it's "clean runClient" instead of "clean build")

   
Executing gradle command: clean build
FAILURE: Build failed with an exception.
* What went wrong:
Could not determine java version from '9.0.1'.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Task completed with return code 1 in 1656 milliseconds

I don't know how to solve this and I tried searching for the problem but I couldn't find a solution. I checked if my java needed updating but it says "your system has the recommended version of java" and the java version is "Java 8 Update 161"(just wanted to mention this just in case). Anyway thank you for reading my issue and I hope this can be solved so I can start making mods.

Issue comments

MCreator only works with Java 8. You are using Java 9. Please make Java 8 as the default Java version on your computer.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.