Failed Gradle build -23

Published by Point_Less on Wed, 06/06/2018 - 16:18
Status
Fixed
Type
Product/platform
Not applicable
Priority
Normal
Issue description
   
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
Microsoft Windows [Version 10.0.17134.48]
(c) 2018 Microsoft Corporation. All rights reserved.
C:\Pylo\MCreator179>cd forge
C:\Pylo\MCreator179\forge>SET "JAVA_HOME=C:\Pylo\MCreator179\jdk\"
C:\Pylo\MCreator179\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator179\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator179\forge>SET "GRADLE_USER_HOME=C:\Users\MindS\.mcreator\gradle"
C:\Pylo\MCreator179\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms512m -Xmx1500m" cleanCache clean setupDecompWorkspace --refresh-dependencies --offline 
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> Could not resolve all dependencies for configuration ':classpath'.
> Could not resolve net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT.
     Required by:
         :forge:unspecified
> No cached version of net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT available for offline mode.
> No cached version of net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT available for offline mode.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 4.806 secs
C:\Pylo\MCreator179\forge>
Task completed with return code 0 in 5974 milliseconds

I downloaded 1.7.9 and I get this error when I try to open MCreator. I have tried to disable my firewall for MCreator, I have tried to redownload MCreator and also Forge, I have tried to delete caches in my gradle folder and this was all done with an internet connection. So... what's the problem?

Issue comments

Ah sorry, I fixed it myself.

I deleted C:\Users\USER\.mcreator\gradle folder

And I edited C:\Users\MindS\.mcreator\preferences file. In it there should be an "offline" thing, so I just set that from true to false and boom, it worked! :D

this did not work for me and the offline thing was already set to false, this is so annoying and looks like its been an issue with mcreator for a while, will this ever get fixed? I've literally tried everything and personally, I feel like there is no hope I'm about to give up on my mod, I've been searching for a fix for 6 hours



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.