Crash on entering new dimension

Published by Milhouseur on Thu, 06/28/2018 - 20:21
Status
Duplicate
Type
Product/platform
Not applicable
Priority
Normal
Issue description

So I'm trying to enter a custom dimension when colliding with a custom block, and without any apparent reason it keeps crashing when trying to load said dimension.
I've tried preloading the dimension with the "built-in" portal (this portal works), tried with multiple dimensions and a clean workspace and it just keeps crashing.

Here are the gradle logs starting from when I collide with the block :

https://pastebin.com/8ckTZmTG

Attachment Size
DimensionCrash.jar47.75 KB 47.75 KB

Issue comments

Thank you for opening a support ticket. Could you please attach the workspace and instruct me how to reproduce this bug with your mod? Thanks!

Thanks for the quick response, here's the mod attached to the original post!
You can easily reproduce it, all you have to do is :

  • Create a new dimension
  • Create a new block
  • Create a procedure with the "Switch dimension for provided entity" block
  • Attach the procedure to the "When player collides" event


Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.