Minecraft crashes when i try loading the mod (Stage 3)

Published by cln2005 on Fri, 07/06/2018 - 07:15
Status
Works as designed
Product/platform
Not applicable
Priority
Normal
Issue description

[23:54:51] [Client thread/INFO]: Setting user: cln2005
[23:55:06] [Client thread/WARN]: Skipping bad option: lastServer:
[23:55:06] [Client thread/INFO]: LWJGL Version: 2.9.4
[23:55:16] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Blockbuster, FMLFileResourcePack:ChiliFriesMod, FMLFileResourcePack:Metamorph, FMLFileResourcePack:WorldEdit, bibliocraft_paintings_example_resource_pack.zip, Ben's Watches
[23:55:28] [Client thread/WARN]: Invalid sounds.json
java.lang.NullPointerException
    at net.minecraft.client.audio.SoundHandler.func_110549_a(SourceFile:82) [bzw.class:?]
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110542_a(SimpleReloadableResourceManager.java:122) [bxi.class:?]
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:446) [bcx.class:?]
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351) [bcx.class:?]
    at net.minecraft.client.main.Main.main(SourceFile:124) [Main.class:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_171]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_171]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_171]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_171]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
[23:55:28] [Client thread/WARN]: Invalid sounds.json
java.lang.NullPointerException
    at net.minecraft.client.audio.SoundHandler.func_110549_a(SourceFile:82) [bzw.class:?]
    at net.minecraft.client.resources.SimpleReloadableResourceManager.func_110542_a(SimpleReloadableResourceManager.java:122) [bxi.class:?]
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:446) [bcx.class:?]
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351) [bcx.class:?]
    at net.minecraft.client.main.Main.main(SourceFile:124) [Main.class:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_171]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_171]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_171]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_171]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
[23:55:28] [Sound Library Loader/INFO]: Starting up SoundSystem...
[23:55:29] [Thread-9/INFO]: Initializing LWJGL OpenAL
[23:55:29] [Thread-9/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[23:55:30] [Thread-9/INFO]: OpenAL initialized.
[23:55:30] [Sound Library Loader/INFO]: Sound engine started
[23:55:53] [Client thread/INFO]: Created: 16x16 textures-atlas
 

Issue comments

You most likely imported a sound with an invalid name or manually modified the sounds.json file. I suggest you go to the user folder inside MCreator's installation location and remove the sound.list file and sound folder. If you have any custom sounds, you will need to import them again.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.