Build Failed when making gui

Status
Works as designed
Type
Product/platform
Not applicable
Priority
Normal
Issue description

Whenever I go to make a GUI, it fails to build and i'm not sure why?

 

:clean
:deobfCompileDummyTask
:deobfProvidedDummyTask
:sourceApiJava
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
C:\Pylo\MCreator179\forge\build\sources\main\java\mod\mcreator\mcreator_blockGui.java:79: error: cannot find symbol
         if (ent != null && (ent instanceof mcreator_demo.TileEntityCustom))
                                                         ^
  symbol:   class TileEntityCustom
  location: class mcreator_demo
1 error
:compileJava FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 15.775 secs
C:\Pylo\MCreator179\forge>
Task completed with return code 0 in 16431 milliseconds

Issue comments

If you bind a GUI to a block, a block needs to have an inventory. Open editor for the block called Demo and enable the inventory/container of this block in the editor.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.