Gradle Task Failed

Published by Super_m on Mon, 08/27/2018 - 20:36
Status
Outdated
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I got this error message after I tried numerous times to start minecraft test environment. This error started to occur after I submitted my mod to the website.

 

   
Executing gradle command: clean runClient
Microsoft Windows [Wersja 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeľone.
C:\Pylo\MCreator179>cd forge
C:\Pylo\MCreator179\forge>SET "JAVA_HOME=C:\Pylo\MCreator179\jdk\"
C:\Pylo\MCreator179\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator179\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator179\forge>SET "GRADLE_USER_HOME=C:\Users\user\.mcreator\gradle"
C:\Pylo\MCreator179\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean runClient 
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
#################################################
         ForgeGradle 2.3-SNAPSHOT-ee3e3df        
  https://github.com/MinecraftForge/ForgeGradle  
#################################################
                 Powered by MCP                  
             http://modcoderpack.com             
     by: Searge, ProfMobius, R4wk, ZeuX          
     Fesh0r, IngisKahn, bspkrs, LexManos         
#################################################
:clean
:deobfCompileDummyTask
:deobfProvidedDummyTask
FAILURE: Build failed with an exception.
* What went wrong:
java.lang.NullPointerException (no error message)
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
:sourceApiJava
BUILD FAILED
Total time: 11.819 secs
C:\Pylo\MCreator179\forge>
Task completed with return code 0 in 12379 milliseconds

 

I just don't understand what went wrong. Are there any solutions to this problem?

Issue comments

So the error only happens when you run the test Minecraft environment and not when you are recompiling the mod?

yes. I tthink I've create the error that happens when you try to launch both test environment and regular minecraft at the same time, I've seen this issue being talked about on some other threads.

Fortunately I've managed to get rid of this bug by restoring MCreator to factory settings. Though I would appraciate to maybe give a link on the application to a page that would disccuss all common bugs, if ofcourse said thing doesn't already exsist.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.