Something is wrong w/ the build...

Status
Fixed
Type
Product/platform
Not applicable
Priority
Normal
Issue description

Executing gradle command: clean build
Build info: MCreator 1.8.1, 64-bit, 3541 MB, Windows 8.1 - cmd, JVM 1.8.0_172, JAVA_HOME: C:\Pylo\MCreator181\.\jdk
C:\Pylo\MCreator181\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean build 
Etag download for https://files.minecraftforge.net/maven/de/oceanlabs/mcp/versions.json f…
Etag download for http://export.mcpbot.bspk.rs/versions.json failed with code 400
Etag download for https://files.minecraftforge.net/maven/net/minecraftforge/forge/json fa…
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 38.566 secs
C:\Pylo\MCreator181\forge>
Task completed with return code 0 in 40343 milliseconds
   
Executing gradle command: clean runClient
Build info: MCreator 1.8.1, 64-bit, 3541 MB, Windows 8.1 - cmd, JVM 1.8.0_172, JAVA_HOME: C:\Pylo\MCreator181\.\jdk
C:\Pylo\MCreator181\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean runClient 
Etag download for https://files.minecraftforge.net/maven/de/oceanlabs/mcp/versions.json f…
Etag download for http://export.mcpbot.bspk.rs/versions.json failed with code 400
Etag download for https://files.minecraftforge.net/maven/net/minecraftforge/forge/json fa…
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 40.168 secs
C:\Pylo\MCreator181\forge>
Task completed with return code 0 in 41800 milliseconds

Issue comments

I suggest you to go to your user folder, go to .mcreator subdirectory and delete the folder called gradle in it. Then remove all files from installation from MCreator. Then try to install MCreator again.

Make sure you have a reliable internet connection and nothing is obstructing MCreator from accessing the internet too.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.