Problem to install the app with Java

Published by Zrunner on Wed, 01/16/2019 - 23:13
Status
Fixed
Product/platform
MCreator/macOS
Priority
Normal
Issue description

Hello,

I tried tonight to reinstall the MCreator application, after having abandoned it for several years due to too many bugs. So I got into my new Mac, and downloaded the latest version available. However, when I launch the app, either by click or via a java command, it tells me that I am currently using Java 11. This is indeed what the command "java --version" returns to me. However, when I go to my Mac's preferences, the Java control panel tells me that I have the latest version of Java 8, no more.
I have tried a couple of manipulations, but none of them work, and the one you linked refers to an article from a year ago, not working any more than the rest. I don't have a /usr/lib/jvm folder contrary to what I read, and I don't want to uninstall java 11 for the moment.

Hoping that you will find a solution to my problem, before I give up again as I did several years ago,
Best regards

 

Z_runner

Attachment Size
Screenshot of the crash report pasted by the app65.15 KB 65.15 KB

Issue comments

It is hard to say how to switch Java for your specific Mac setup. The default Java version on your computer should be Java 8 in order for MCreator to work. You can check the following resources I have found on how to set Java 8 as default Java on your Mac:

MCreator 2.x.x or even earlier will pack own Java distribution as it is the case with Windows version for Mac and Linux too.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.