Gradle Task Failed When setting up

Published by MLPGirl24 on Fri, 02/15/2019 - 19:28
Status
Duplicate
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Whenever i open up mcreator i keep getting this issue 

 

   
Executing gradle command: wrapper --gradle-version 4.4
Build info: MCreator 1.8.2, 64-bit, 3562 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" wrapper --gradle-version 4.4 
FAILURE: Build failed with an exception.
* Where:
Build file 'C:\Pylo\MCreator182\forge\build.gradle' line: 10
* What went wrong:
A problem occurred evaluating root project 'forge'.
> org.gradle.api.internal.TaskOutputsInternal.dir(Ljava/lang/Object;)Lorg/gradle/api/tasks/TaskOutputFilePropertyBuilder;
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 24.103 secs
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 25692 milliseconds
   
Executing gradle command: wrapper --gradle-version 4.4
Build info: MCreator 1.8.2, 64-bit, 3562 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms707m -Xmx2085m" wrapper --gradle-version 4.4 
FAILURE: Build failed with an exception.
* Where:
Build file 'C:\Pylo\MCreator182\forge\build.gradle' line: 10
* What went wrong:
A problem occurred evaluating root project 'forge'.
> org.gradle.api.internal.TaskOutputsInternal.dir(Ljava/lang/Object;)Lorg/gradle/api/tasks/TaskOutputFilePropertyBuilder;
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 28.228 secs
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 31298 milliseconds

 

ive reinstalled it , its on online mode , an i cant find the cache folder , its not installed , i tried to fix it on my own but i dont know the solution ,, i uped the ram and is on 64 bit which is my os as well ...... please help :( ,, p.s i dont know if this would go in bug report or support issue ---- 

Issue comments

The fix for this is the following:

  1. Go to your user folder and in this folder, go to a folder called .mcreator. In this folder, delete a folder called gradle
  2. Reboot your computer
  3. Run MCreator again

If this does not help, try the following:

  1. Go to your user folder and in this folder, go to a folder called .mcreator. In this folder, delete a folder called gradle
  2. Completely reinstall MCreator
  3. Run the setup again

If this does not help, you might need to try the second guide a few times (I had to do it 2 times to make it work).

This issue was caused by an outdated repository that was in use by Minecraft Forge and their development gradle toolkit needs to be updated.

More info in this forum topic: https://mcreator.net/forum/47021/mcreator-cant-install



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.