Unable to set more than 3 crafting recipes for my block (edited and reposted)

Status
Duplicate
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I'm editing this issue to report that I've tried to change the procedure to fix it myself and I don't remember if the previous mcr file I attached had the problem where the 4th crafting recipe if statement in my LogSawmillCrafting Procedure outputs the 2nd crafting recipe's output or not but now my current LogSawmillCrafting is doing so. So I'm uploading my more up to date mcr file as well so that it might be looked at as well.

Below this point is older messages:

I reopened my issue since I think It is no longer possible to get help with my issue on my old issue post so I'm posting it again, this time with my mcr file so that my workspace may be looked at. The name of the procedure that I'm having the issue below with is named LogSawmillCrafting.

The issue is as follows:

I set up a crafting block using procedures and gui like it was done is this tutorial video here:

https://www.youtube.com/watch?v=qdGJY7ljujM&feature=youtu.be&t=604

However I noticed it doesn't seem to allow me to set up more than 3 crafting recipes. As when I tried to add up to 7 of them for everyone below the 3rd crafting recipe it outputs the same as the 3rd recipe even though i have them all set to output different blocks from one another. I don't know what the issue is for why it is doing this but if it can be looked into it would be much appreciated.

Attachment Size
ModProject_TemporaryName.mcr340.61 KB 340.61 KB
ModProject_TemporaryName(updated).mcr476.63 KB 476.63 KB

Issue comments

I have answered in your original ticket, we just closed it as you did not reply and assumed you fixed it on your own.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.