Living entity just floats at current Y level and attacks player if they touch, but doesn't move.

Published by typecasto on Sun, 03/29/2020 - 07:08
Status
Duplicate
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I've been trying to create a mob for a while now, and it worked at first (albeit jumping a bit high at default settings) but once I upgraded from 2020.1 to 2020.2 I've been unable to create working mobs. The mob just floats in mid air, moving horizontally if you punch it, but never moving vertically unless it gets heavy knockback. I've tried simplifying the AI to just walk, look around, and swim if water, but nothing works. The entity is NOT set to floating, and since updated I've deleted the entity and remade it from scratch, but nothing I've done so far has fixed the issue. I've also told the entity to inherit zombie behavior, but nothing has worked.

Issue comments

2020.2.13616

  • [Bugfix #58588, 1.12.2] Boss mobs had gravity disabled in some cases
  • [Bugfix #58509] There were some issues with flying mobs
  • [Bugfix #58595] Author list always included MCreator

Turn on update notifications.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.