MAJOR MAJOR MOD DESTROYING BUG

Published by ttrash on Tue, 05/05/2020 - 22:08
Status
Can not reproduce
Type
Product/platform
MCreator/macOS
Priority
Normal
Issue description

I tried rearranging the creative menu item order, and then Creator got stuck on the second task for 45 minutes, so I was forced to force quit the application. Upon opening back up my workspace, almost every item had a red error triangle. I tried reloading the individual elements and resaving them, which appeared to be working. Except, every time that I would do this, a new element would get the red triangle at the top. I tried resaving the elements as they popped up, except I noticed that some of the elements that I already resaved and appeared to compile correctly had the red triangle reappear.

 

Luckily I had made a backup very recently, so not much was lost, but this absolutely needs to be fixed :)

Issue comments

This sounds like a serious bug, but I would need more info to resolve this.

When possible, attach your MCreator workspace (or even better a minimal example workspace required to reproduce the bug), game logs (full logs, do not crop them, in text format, not screenshots of logs) from the Console tab or terminal and steps to reproduce the bug in your workspace. If logs are long, use service such as Pastebin to host the log and provide the link to the log from the ticket. Please specify which mod elements to check in your workspace too, if applicable.

At least compile logs from that time, workspace, and steps on how to reproduce this would be needed.

Check <user home>/.mcreator/logs for the log from the time that happened if possible too, that would help a lot.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.