Custom sounds seem not to play on key pressed.

Published by Tobi9090 on Fri, 05/22/2020 - 17:06
Status
Can not reproduce
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I've tried searching the site, but i haven't been able to find an issue quite like mine. In essence i've created key binds that should play a custom sound I imported when pressed. I got my sounds by using a Youtube to Ogg converter and each of the sounds is only a few seconds long at max. I can also play the actual files on my desktop so they don't seem to be corrupted. Lastly i've using the /playsound command in minecraft yet no sound plays at all.

I have attached my workspace, you can see the issue by opening a test environment and pressing the dash key(Z) which will launch you in the direction you're looking and should have a sound play along with it.

- thanks for taking the time to read this, any help is appreciated.

 

Attachment Size
Example Workspace416.46 KB 416.46 KB

Issue comments

How did you make ogg file?

The fact that even playsound can't play it indicates the format is not MC compatible.

Thank's for the reply Klemen, I used a youtube to ogg converter for my sound files. they seem to work when i simply click on them in my computers file explorer.

OGG is container for multiple formats. OGG vorbis is needed for MC.

Try converting it using Audacity instead.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.