Mcreator crashed and after using a backup made my project try to compile mod elements that aren't there.

Status
Outdated
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Basically Mcreator v2020.1 crashed (my WiFi is so slow that I don't bother updating on this wifi) and when I went to open it up, it said that my work was corrupted, but I could choose a backup, so I naturally went with the first one (from the top of the list, that is). it just popped up the message again, and I tried the first one about 5 more times before going to the second option, which worked. However, when I went to run the mod, it said that there was a problem compiling and looked like a list of problems, or what would be the problem, because it doesn't state any problems at all. when I go into console, it spams this at me. 

                       ^
C:\Users\teren\MCreatorWorkspaces\help\src\main\java\net\mcreator\theundersidemod\MCreatorCustomFurnace.java:1: error: illegal character: '\u0000' 
      

it says this 100 times, so idk what to do anymore.

Attachment Size
TheUnderside.zip297.64 KB 297.64 KB

Issue comments



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.