Stuck on "Loading MCreator Windows"

Status
Resolved
Type
Product/platform
MCreator/Windows
MCreator version
Priority
Normal
Issue description

Every time I launch MCreator it gets stuck on "Loading MCreator Windows". I saw a similar problem someone else posted & have tried the following suggestions with no success.
Reboot
Uninstall (with the keep settings data checkmark unchecked )
Reboot
Install (without launching)
Reboot
launch

I also tried "going to <user home>/.mcreator and delete file called recentworkspaces" but there was no file there as I have never gotten the program open before.

Issue comments

Nvm I fixed it. Running the bat file said that JNA native library 4.4.0 detected 5.1.0 expected. I downloaded the jar for it and replaced the 4.4.0 version in the lib folder & it successfully launched. Not sure why it had the wrong version. I uninstalled & reinstalled several times.

This most likely happened because old version Java was still running in the background when you installed new version and some files were locked and were not replaced by new ones.

I recommend you reboot PC to release all file locks and reinstall the version again.

I had already done that my dude, see the original description

You only replaced some files. You might run into bugs down the road if other files were affected...

like i said in the description, Ive tried rebooting before & in between uninstall/reinstall. Not sure how doing something I've already done more than once is going to change anything. If I run into a bug I'll cross that bridge when I come to it.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.