problem running a procedure with pixelmon commands.

Started by Quomvi on

Topic category: Help with modding (Java Edition)

Last seen on 20:23, 5. Oct 2023
Joined Aug 2023

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
problem running a procedure with pixelmon commands.
Wed, 08/30/2023 - 21:15 (edited)

so i am making a mod that adds some stuff for a server i'm playing with my friends, and i have different things through a GUI (running a pc command, pokeheal and a trade command, they work perfectly), but when i try to make a button use the commands ''ivs'' and  ''evs'' it doesn't do anything, are there certain commands that can't work through a procedure? the test world i'm using has cheats enabled and i have max perm, and i've tried using the commands just on their own and with both ''execute as @p run'' and ''execute as @s run''.

i tried to use it with a command block as a ''execute as @p run evs 1'' and it also doesn't work, it only does when i do it through chat, so apparently the command acts like that, is there a name for that? or a solution on how to make it work?.

Edited by Quomvi on Wed, 08/30/2023 - 21:15