When was Spawn warden supported?

Started by Nate0tmi on

Topic category: Mod design feedback

Last seen on 06:11, 10. Jul 2024
Joined Oct 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
When was Spawn warden supported?

So many mods I have work on 1.18.2 & so I have both an old ver of Mcreater & the new ver installed.  I see the warden stuff is not fully supported, but when making a biome we can pick "The warden" to spawn just like any other mob we want in that biome.  Yet will the warden really spawn in 1.18.2 with Mcreater mods?  or is my only choice to update & remake my mods for newer ver of Minecraft as 1.18.2 is no longer in the new ver of Mcreater?  So I installed both 2023.1 for making mods in 1.18.2 & 2023.2 for 1.19.2 & I have yet to look at newer ver because of what they will support.  My mods work fine on 1.18.2 & work with 41 mods I found outside of Mcreater.  So I am reluctant to update.  Yet I want the warden in my mod pack.  So do I need to re-make the pack or do I have other choices given I don't know how many mods I can find to work with what I make in Mcreater as I don't want to need to make everything myself, I would like to have other mods in this pack outside of mods made with Mcreater.   What should I do?   if I update do I fully need to remake all my mods?  or can I make a biome in 1.18.2 that spawns the warden, because every thing else I could just make modded blocks for, to simulate the deep dark & mod it.

I have made mobs & blocks & plants & such based on the deep dark & that is to be the theme of a mod I am making in 1.18.2.  (to keep this short)

Last seen on 00:15, 19. Jul 2024
Joined Jul 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Well you can't spawn an…
Fri, 10/27/2023 - 00:48

Well you can't spawn an entity in a version where it doesn't exist, but if you are curious what will happen when you open your mod in a newer version but don't want to fully commit to it updating, you can duplicate your workspace, import it into mcreator under a different name, and update that, then you'll have a version updated and the original without worrying about errors.

Last seen on 06:11, 10. Jul 2024
Joined Oct 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
So your saying, there is a…
Sat, 11/04/2023 - 15:24

So your saying, there is a way to import my mod over to a newly updated Mcreator even if the mod was made for in 1.18.2 & now Mcreator will not make a 1.18.2 mod & there for update my mod to 1.19 or up?   I will try that when I am done testing my mod rather then remaking everything.

Last seen on 00:15, 19. Jul 2024
Joined Jul 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Yes, all you have to do is…
Sat, 11/04/2023 - 18:08

Yes, all you have to do is open your mod in the new version of Mcreator and it will rebuild it and everything should transfer properly.

Last seen on 08:10, 4. May 2024
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I used the command block and…
Sun, 11/19/2023 - 22:54

I used the command block and used a command to make it have the spawn animation lol