Constant window errors when testing Forge modification

Started by ProfessionalDipwad on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:44, 27. Dec 2023
Joined Dec 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Constant window errors when testing Forge modification

I recently downloaded MCreator for Windows, as I had installed it on a Mac previously and it worked perfectly fine. I created a workspace and added some mod elements, currently there are only six. The first time I ran the project it seemed to be working okay, but after a couple minutes the window stopped responding. On attempt two, I got the first error. It stated "Failure to initialize graphics window with current settings. We seem to have run into a problem handing over the window," or something like that. It showed in the console and also as an error alert, and would not stop showing up, the windows overlapped over and over. It had a link to this page: https://blog.minecraftforge.net/meta/displayerrors/ which I looked around on a bit and did some stuff with. I changed splashscreen to false in fml.toml and also updated my drivers. It ended up working so I continued modding. I added two new things, including one procedure (I don't know if that has to do with anything, but it was the most complicated thing I had added so far). It then started giving me the same error about the graphics window. I don't know what to do about this error and haven't found anything on any other forum. The closest thing I found was a Reddit post in which the author had the same problem, but there were no solutions, just people commenting "I had the same issue." If I could get any help, it would be greatly appreciated.