Geckolib Entity/Animation crashes minecraft Forge 1.20.1 (version 47.2.0)

Started by LOLplayer45 on

Topic category: Help with MCreator software

Last seen on 00:26, 16. Jan 2024
Joined Dec 2019

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Geckolib Entity/Animation crashes minecraft Forge 1.20.1 (version 47.2.0)

I tried to create a custom entity using the Geckolib plugin on Mcreator using Blockbench. I made the model, texture and animation and exported the geckolib model and animations/textures and stuff. I created the entity in mcreator, but when I tried spawning it in in minecraft, the game just displays "saving world" and just crashes. The animation has the same name in the files and blockbench as it does in the Mcreator settings, and I do have an idle animation, also with the proper name. I've tried remodelling, re-saving the animations and files, but nothing seems to work. Inside the mcreator console it says:

 "Caused by: software.bernie.geckolib.GeckoLibException: exmaple_mod:animations/example.animation.json: Unable to find animation." 


What??? Unable to find animation??! What is going on?? Everything is the way it should be and I'm either doing something horribly wrong or maybe Geckolib just sucks. Oh yeah, and I've tried doing it with the Java Modded Entity models instead, and that still crashed the game.



I would recommend getting in…
Sun, 01/14/2024 - 16:41

I would recommend getting in touch with the author, as reporting problem here is not really addressing it to the right location. I have seen this problem before and usually it is due to not using the plugin properly