Geckolib texture change not working (solved)

Started by ShadowMaster1717 on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 01:31, 16. Mar 2024
Joined Feb 2024

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Geckolib texture change not working (solved)
Mon, 02/26/2024 - 22:58 (edited)

So, I have a mob that I want to have randomised. I have code on the entities spawn using the geckolib addon, which if a random 0-1 block's value is greater than an amount it will change the texture. I don't know why, but it isn't changing in-game, and I do not know what is going on. I have been able to use the block in anothother mod and it worked perfectly, so I don't know what is wrong, or how to fix it. This may just be me messing up the random or the names. Thanks, though!


Edit: I tried just setting the texture, no random blocks, and it didn't work either. I don't know what is wrong...

Edit 2: I don't know exactly what I did but I think i just had some initial problem, accidentally solved it but added a usless .png to the end of the name in the block, forgot to remove it, eventually did, and solved my problem :)

Edited by ShadowMaster1717 on Mon, 02/26/2024 - 22:58