Whenever I run a Gradle task, is says "Execution failed for task ':downloadMcpConfig'."

Started by Play-Face on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 12:04, 13. May 2024
Joined Aug 2022

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Whenever I run a Gradle task, is says "Execution failed for task ':downloadMcpConfig'."

Whenever I try to run client, or most gradle tasks, I'm met with this test:
"Executing Gradle task: build
Build info: MCreator 2023.4.52316, forge-1.20.1, 64-bit, 8055 MB, Windows 10, JVM 17.0.9, JAVA_HOME: C:\Users\Adam\Desktop\Pin to quick access\Mcreator\jdk, started on: 2024-04-08-19:57:01
Loaded APIs: geckolib

> Task :compileJava
> Task :processResources
> Task :classes
> Task :jar
> Task :downloadMcpConfig FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':downloadMcpConfig'.
> java.nio.file.AccessDeniedException: D:\MCreatorWorkspaces\The_13_Realms\build\downloadMcpConfig\output.zip
* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
* Get more help at https://help.gradle.org
4 actionable tasks: 4 executed

Task completed in 18 seconds"


I copied D:\MCreatorWorkspaces\The_13_Realms\build\downloadMcpConfig\output.zip and searched which lead me to config.json. There was a couple different files, but I think this one is the problem because next to it it said 88%. I don't know how to get screenshots on here so I'll link a slide