Custom grass not generating

Started by Mistifikat on

Topic category: Help with modding (Java Edition)

Last seen on 23:20, 21. Jun 2024
Joined Sep 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Custom grass not generating

In version 2024.1.18518 I am trying in vain to get custom grass to be generated. And this is more like a mockery. I set any values I wanted, even such that, according to the tooltip, there should be more grass than air (sarcasm) in my world, but it either does not occur at all, creating lifeless plateaus, or it occurs SO RARE that in this world it will be more valuable any material, I think even antimatter will be less valuable than a bunch of grass. 
I don't know how to insert photos on this site, but I'll post where and what I've put
I am trying to make a grass that is created as a plant. Then, in the “generation” tab, the following values are set:

Check to enable plant feature geneartion in the world: false
Spawn frequency on chunks: 4
Patch size: 64
Generate plant at any height: yes
Generation type: grass 
Restriction biomes: MyBiome

It is either not generated at all or very little. Regardless of the values I set, whatever they are, it is still almost nonexistent. Why that is, I don't know.
In all biomes I have custom trees (i.e., a vanilla tree template, but with different blocks), and there is a biome without these trees. In neither of those, my grass is almost nonexistent, so those trees hardly interfere with its generation. 
The special (my) grass block on which grass can grow has the “can plants grow on this block?” option enabled.

Please help me solve this problem, and you will have +20% luck by the end of next week, I guarantee

Last seen on 21:41, 18. Jun 2024
Joined May 2024
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Shot in the dark here but I…
Thu, 05/30/2024 - 07:22

Shot in the dark here but I figure anything will help. Go into your "plant" element where you set up the custom grass, then in advance make sure the block that you want it to grow on is in the "optional list" saying where it is allowed to grow. not sure if that will fix your problem but it's worth a shot! 

Last seen on 23:20, 21. Jun 2024
Joined Sep 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Did not workI even tried to…
Thu, 05/30/2024 - 18:26

Did not work
I even tried to make a separate world, a new bimo for it, made 2 types of the same grass: one that has this list, and one that doesn’t, and neither one nor the other is generated.