gradlew build Error

Started by Valtencir Buachak on Sat, 10/01/2016 - 09:48

Topic category: Bugs and solutions

Last seen on 18:01, 25. Sep 2017
Joined Sep 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
gradlew build Error
Sat, 10/01/2016 - 09:53 (edited)

I'm new here and working with the new MCreator (only 2 days), it was working properly but suddenly there was a problem building the mods and can't fix it.

I had made one mod normally and not know what it happened to appear this problem. Please I need help to continue learning in the creation of mods

 

Microsoft Windows [version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Todos os direitos reservados.
C:\Program Files (x86)\Pylo\MCreator 1.6.3>cd forge
C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge>SET "JAVA_HOME=C:\Program Files (x86)\Pylo\MCreator 1.6.3\jdk\"
C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge>gradlew build
FAILURE: Build failed with an exception.
* Where:
Build file 'C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge\build.gradle' line: 18
BUILD FAILED
Total time: 19.111 secs
* What went wrong:
A problem occurred evaluating root project 'forge'.
> No such property: plugin for class: org.gradle.api.internal.project.DefaultProject_Decorated
Possible solutions: plugins

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
C:\Program Files (x86)\Pylo\MCreator 1.6.3\forge>
Task completed with return code 0 in 20050 milliseconds
Task return code check OK!

 

That's my gradlew build :

 

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'      <<<<<<<  THIS IS THE LINE 18  >>>>>>>

version = "1.0"
group = "com.yourname.modid" // http://maven.apache.org/guides/mini/guide-naming-conventions.html 
archivesBaseName = "modid"

minecraft {
    version = "1.7.10-10.13.4.1614-1.7.10"
    runDir = "eclipse"
}

 

 

Edited by Valtencir Buachak on Sat, 10/01/2016 - 09:53
Last seen on 19:37, 5. Jun 2017
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I have this same problem!
Sat, 10/01/2016 - 17:27

I have this same problem!

Please someone must help!

  • I can't create mods!
  • I ahave problem with installing forge!
  • ​Please help me!
Last seen on 19:37, 5. Jun 2017
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:I have this same problem!
Sat, 10/01/2016 - 17:28

This is what i have!

 

BOOTING UP GRADLE...
Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 0 milliseconds]
RIGHT click once to copy log to the clipboard or twice to clear the log.
   
Executing gradle command: clean runClient
Microsoft Windows [Wersja 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeľone.
C:\Pylo\MCreator>cd forge
C:\Pylo\MCreator\forge>SET "JAVA_HOME=C:\Pylo\MCreator\jdk\"
C:\Pylo\MCreator\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator\forge>SET "JAVA_OPTS=-Xmx502m -Xms300m"
C:\Pylo\MCreator\forge>gradlew clean runClient
FAILURE: Build failed with an exception.
* What went wrong:
A problem occurred configuring root project 'forge'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Unexpected lock protocol found in lock file. Expected 3, found 0.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 13.799 secs
C:\Pylo\MCreator\forge>
Task completed with return code 0 in 14938 milliseconds
Task return code check OK!

Last seen on 22:00, 11. Nov 2019
Joined Aug 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
First, you should probably
Sat, 10/01/2016 - 20:57

First, you should probably move your Pylo folder from Programs(x86) and place it directly in C:\, as windows can get odd about storing stuff from those locations. Then, try opening mCreator as "administrator" and let me know if that works. If not, go into your pylo folder, users, etc, and backup your workspace and textures and whatnot, then delete the Pylo folder and redownload the installer for a clean copy of mCreator.

 

Last seen on 18:01, 25. Sep 2017
Joined Sep 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I did the way you said...but
Tue, 10/04/2016 - 18:53

I did the way you said...but the error remains :(