i don't get this error

Started by HEroBrinEkill1 on Thu, 12/28/2017 - 15:31

Topic category: General discussion

Last seen on 16:38, 10. Dec 2019
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
i don't get this error
Thu, 12/28/2017 - 15:31

16:28:55] [main/INFO]: Created: 512x512 textures-atlas
[16:28:56] [main/INFO]: Applying holder lookups
[16:28:56] [main/INFO]: Holder lookups applied
[16:28:56] [main/INFO]: OBJLoader: Domain testenvironmentmod has been added.
[16:28:56] [main/FATAL]: Fatal errors were detected during the transition from INITIALIZATION to POSTINITIALIZATION. Loading cannot continue
[16:28:56] [main/FATAL]: 
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   | State | ID                 | Version      | Source                           | Signature |
   |:----- |:------------------ |:------------ |:-------------------------------- |:--------- |
   | UCHI  | minecraft          | 1.12.2       | minecraft.jar                    | None      |
   | UCHI  | mcp                | 9.42         | minecraft.jar                    | None      |
   | UCHI  | FML                | 8.0.99.99    | forgeBin-1.12.2-14.23.0.2491.jar | None      |
   | UCHI  | forge              | 14.23.0.2491 | forgeBin-1.12.2-14.23.0.2491.jar | None      |
   | UCHE  | testenvironmentmod | 1.0          | modid-1.0.jar                    | None      |
[16:28:56] [main/FATAL]: The following problems were captured during this phase
[16:28:56] [main/ERROR]: Caught exception from testenvironmentmod (java.lang.ArrayIndexOutOfBoundsException: 3)
[16:28:56] [main/INFO]: [net.minecraft.init.Bootstrap:printToSYSOUT:553
// Shall we play a game?
Time: 12/28/17 4:28 PM
Description: There was a severe problem during mod loading that has caused the game to fail
AL lib: (EE) alc_cleanup: 1 device not closed
net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from testenvironmentmod (testenvironmentmod)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 3
   at net.minecraftforge.common.crafting.CraftingHelper.parseShaped(CraftingHelper.java:302)
   at net.minecraftforge.fml.common.registry.GameRegistry.addShapedRecipe(GameRegistry.java:202)
   at mod.mcreator.mcreator_bigdiamond.load(mcreator_bigdiamond.java:66)
   at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:938)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:611)
Picked up _JAVA_OPTIONS: -Xmx20G 
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
   at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
   at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
   at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
   at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
   at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
   at com.google.common.eventbus.EventBus.post(EventBus.java:217)
   at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:253)
   at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:231)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
   at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
   at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
   at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
   at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
   at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
   at com.google.common.eventbus.EventBus.post(EventBus.java:217)
   at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:148)
   at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:781)
FAILURE: Build failed with an exception.
   at net.minecraftforge.fml.client.FMLClientHandler.finishMin   at net.minecraft.client.Minecraft.init(Minecraft.java:534)
ecraftLoading(FMLClientHandler.java:348)
* What went wrong:
   at net.minecraft.client.Minecraft.run(Minecraft.java:377)
Execution failed for task ':runClient'.
   at net.minecraft.client.main.Main.main(SourceFile:123)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> Process 'command 'D:\mcreator versions\MCre* Try:
ator176\jdk64\bin\java.exe'' finished with non-zero exit value -1
Run with --stacktrace option to get the stack trace. Run with --info or --debug opti   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
on to get more log output.
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
   at GradleStart.main(GradleStart.java:26)
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
   Minecraft Version: 1.12.2
   Operating System: Windows 10 (amd64) version 10.0
   Java Version: 1.8.0_101, Oracle Corporation
   Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
   Memory: 745650888 bytes (711 MB) / 1158676480 bytes (1105 MB) up to 19088801792 bytes (18204 MB)
   JVM Flags: 1 total; -Xmx20G
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: MCP 9.42 Powered by Forge 14.23.0.2491 5 mods loaded, 5 mods active
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   | State | ID                 | Version      | Source                           | Signature |
   |:----- |:------------------ |:------------ |:-------------------------------- |:--------- |
   | UCHI  | minecraft          | 1.12.2       | minecraft.jar                    | None      |
   | UCHI  | mcp                | 9.42         | minecraft.jar                    | None      |
   | UCHI  | FML                | 8.0.99.99    | forgeBin-1.12.2-14.23.0.2491.jar | None      |
   | UCHI  | forge              | 14.23.0.2491 | forgeBin-1.12.2-14.23.0.2491.jar | None      |
   | UCHE  | testenvironmentmod | 1.0          | modid-1.0.jar                    | None      |
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 388.71' Renderer: 'GeForce GTX 1060/PCIe/SSE2'
[16:28:56] [main/INFO]: [net.minecraft.init.Bootstrap:printToSYSOUT:553
:runClient FAILED
BUILD FAILED
Total time: 45.208 secs
Picked up _JAVA_OPTIONS: -Xmx20G 
D:\mcreator versions\MCreator176\forge>
Task completed with return code 0 in 45741 milliseconds

Last seen on 16:38, 10. Dec 2019
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
i have no learn code but…
Thu, 12/28/2017 - 15:41

i have no learn code but what is this error 

Last seen on 16:38, 10. Dec 2019
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
ok 
Fri, 12/29/2017 - 00:42

ok