Problem: broken aspect ratio and not an animation (json custom model)

Started by Celestials on Thu, 03/15/2018 - 21:42
Last seen on 17:05, 21. Mar 2018
Joined Mar 2018
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Problem: broken aspect ratio and not an animation (json custom model)
Thu, 03/15/2018 - 21:42

hello i'm french sorry for my english approximate

mcreator version: 1.7.8

I created a 3d model with models creator I applied the texture (0, 1 ...) but in the game I have the purple and black texture.

 

my block code :

{
    "__comment": "Model generated using MrCrayfish's Model Creator (http://mrcrayfish.com/modelcreator/)",
    "textures": {
        "0": "blocks/bookretop",
        "1": "blocks/bookrec",
        "2": "blocks/bookcoter",
        "3": "blocks/booktop"
    },
    "elements": [
        {
            "name": "Cube",
            "from": [ 2.0, 0.0, 2.0 ], 
            "to": [ 13.0, 3.0, 15.0 ], 
            "faces": {
                "north": { "texture": "#0", "uv": [ 0.0, 0.0, 16.0, 16.0 ], "rotation": 180 },
                "east": { "texture": "#1", "uv": [ 0.0, 0.0, 16.0, 16.0 ], "rotation": 270 },
                "south": { "texture": "#0", "uv": [ 0.0, 0.0, 16.0, 16.0 ] },
                "west": { "texture": "#2", "uv": [ 0.0, 0.0, 16.0, 3.0 ] },
                "up": { "texture": "#3", "uv": [ 0.0, 0.0, 16.0, 16.0 ] },
                "down": { "texture": "#-1", "uv": [ 0.0, 0.0, 11.0, 13.0 ] }
            }
        }
    ]
}

And in the console of mcreator  :

[20:59:30] [main/ERROR] [TEXTURE ERRORS]:     The following other errors were reported for domain minecraft: [20:59:30] [main/ERROR] [TEXTURE ERRORS]: ------------------------- [20:59:30] [main/ERROR] [TEXTURE ERRORS]:     Problem: broken aspect ratio and not an animation [20:59:30] [main/ERROR] [TEXTURE ERRORS]:       textures/blocks/bookcoter.png [20:59:30] [main/ERROR] [TEXTURE ERRORS]:       textures/blocks/bookretop.png [20:59:30] [main/ERROR] [TEXTURE ERRORS]:       textures/blocks/vine.png [20:59:30] [main/ERROR] [TEXTURE ERRORS]:       textures/blocks/bookrec.png [20:59:30] [main/ERROR] [TEXTURE ERRORS]: ================================================== [20:59:30] [main/ERROR] [TEXTURE ERRORS]: +=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=

Thank you for the help !

 

Last seen on 17:05, 21. Mar 2018
Joined Mar 2018
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Problem solved
Sat, 03/17/2018 - 15:02

Problem solved