Need help! armor texture not working

Started by Agent-51 on Fri, 05/11/2018 - 01:27

Topic category: General discussion

Last seen on 16:37, 11. May 2018
Joined May 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Need help! armor texture not working
Fri, 05/11/2018 - 01:27

First I want to ask is there any official instructions for this application ie. list of terms cause whenever i click a question mark next to something I don't understand it just pastes the whole line of text before it in the search box here which is rarely of any help. And now my original question. I am trying to make an armor mod with my player skin. i created the texture and imported it but when i test the mod the entier texture (leggings,boots, helmet, chestplate...) appears on the head and the rest of the body looks the same or is non existant. i used the same template as vanilla armor when creating this too. how do i fix this?

 

Last seen on 19:03, 1. Jun 2020
Joined Apr 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
You have to divide the amor…
Tue, 05/15/2018 - 16:17

You have to divide the amor texture into 2 layers!

Because in Minecraft, armors have a texture that is divided in 2 different parts (Layers).

For example (Diamond Armor): the first file is named like this -> diamond_layer_1

  • which includes the Helmet and the Chestplate texture part.

 

The second one is named like this -> diamond_layer_2

  • which includes the Leggins and the Boots texture part

 

If you make this "custom" armor texture like I said before (and then import it on MCreator) it should be fine.

 

Reply this comment if doesn't work!

 

Your faithful, M4ttix