Gui Crafting Problem

Started by Motte333 on Sun, 09/02/2018 - 18:45

Topic category: Bugs and solutions

Last seen on 11:18, 15. Feb 2020
Joined Apr 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Gui Crafting Problem
Sun, 09/02/2018 - 18:45

I have a problem, when i make a gui (and procedure etc) to make a custom crafting bench most things work but when i launch mc and try it out it does remove the first item in slot 1 , damage another in slot 0 (like i want it to) and spawn the crafted item in slot 2 but when i click it it returns to before like i never crafted it its weird: the dealt damage resets to full the removed item reappears and the crafted item dissapears its a problem wich prevents me from making my mod, any solutions?

This is a known bug. Use…
Mon, 09/03/2018 - 07:01

This is a known bug. Use block inventory management blocks, not the GUI, as instructed in the procedure editor too.

Last seen on 11:18, 15. Feb 2020
Joined Apr 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Problem: That would only…
Mon, 09/03/2018 - 08:23

Problem: That would only work for a block crafting bench but i have it so when you right click a item it opens the crafting gui (3 slots its for turning 1 item into another) but if there's no solution then ill just make it so you do that with the normal work bench!

 

Thanks anyway

I understand your problem…
Mon, 09/03/2018 - 10:26

I understand your problem. We plan to add support items as containers in the future, until then, the best option is to use blocks instead as you said.