/execute command might be bugged?

Started by Ghoulander on Tue, 02/05/2019 - 23:14

Topic category: Help with MCreator software

Last seen on 17:49, 29. Apr 2020
Joined Feb 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
/execute command might be bugged?
Tue, 02/05/2019 - 23:14

So I created a block. The block has a button inside that when it is pushed it spawns a block 2,2,2 blocks away. (Just for testing sakes)

So I created a Procedure and within the If then there is an 'Execute command /' followed by a text blockly that says 'setblock ~2 ~2 ~2 wool.

I also have a conjoined text line below that that 'Send to chat to all players' 'Command Executed'

It will say 'Command Executed' every time but it however WILL NOT execute a command.

I have tried different commands. I have tried different formats of the commands by leaving the / on there.

I tried editing the code directly (I am by no means a java master but I do know enough of the basics to get by).

Am I missing something here or is this bugged in 1.8.2?

(Gonna fire up 1.8.1 and see if I can't replicate the same results)

 

Last seen on 13:06, 22. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Avoid using execute command…
Wed, 02/06/2019 - 18:11

Avoid using execute command because it only works if cheats are enabled. You can do all the things without the command procedure block using procedures.