caching code to improve performance problem again

Started by Hiveguy on Sun, 02/10/2019 - 00:25

Topic category: Bugs and solutions

Last seen on 04:30, 21. Mar 2019
Joined Feb 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
caching code to improve performance problem again
Sun, 02/10/2019 - 00:25

So i recently tried to install mcreator after a long break and i had a forum topic a week ago but my laptop had to get sent to the shop for other reasons. I am stuck at caching code to improve performance, here is the log. 

 

   
Executing gradle command: wrapper --gradle-version 4.4
Build info: MCreator 1.8.2, 64-bit, 12186 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=true -Dorg.gradle.parallel=true -Dorg.gradle.jvmargs="-Xms1024m -Xmx4000m" wrapper --gradle-version 4.4 
Starting a new Gradle Daemon for this build (subsequent builds will be faster).
FAILURE: Build failed with an exception.
* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at https://docs.gradle.org/2.14/userguide/gradle_daemon.html
Please read the following process output to find out more:
-----------------------
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size
Picked up _JAVA_OPTIONS: -Xmx512M
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Picked up _JAVA_OPTIONS: -Xmx512M
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 3461 milliseconds
   
Executing gradle command: setupDecompWorkspace --refresh-dependencies
Build info: MCreator 1.8.2, 64-bit, 12186 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=true -Dorg.gradle.parallel=true -Dorg.gradle.jvmargs="-Xms1024m -Xmx4000m" setupDecompWorkspace --refresh-dependencies 
Starting a new Gradle Daemon for this build (subsequent builds will be faster).
FAILURE: Build failed with an exception.
* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at https://docs.gradle.org/2.14/userguide/gradle_daemon.html
Please read the following process output to find out more:
-----------------------
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size
Picked up _JAVA_OPTIONS: -Xmx512M
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Picked up _JAVA_OPTIONS: -Xmx512M
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 1841 milliseconds

Last seen on 04:30, 21. Mar 2019
Joined Feb 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
note: i already set the…
Sun, 02/10/2019 - 00:26

note: i already set the memory to 1024 and 4000 respectively

Last seen on 19:20, 20. Apr 2019
Joined Apr 2010
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
  • developer
Do you use 32 or 64 bit…
Sun, 02/10/2019 - 19:02

Do you use 32 or 64 bit version of MCreator?

Last seen on 04:30, 21. Mar 2019
Joined Feb 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
64 bit
Sun, 02/10/2019 - 20:39

64 bit

Last seen on 19:20, 20. Apr 2019
Joined Apr 2010
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
  • developer
Check if you have any global…
Mon, 02/11/2019 - 21:19

Check if you have any global environment variables (https://superuser.com/questions/949560/how-do-i-set-system-environment-…) called _JAVA_OPTIONS or JAVA_OPTIONS on your computer and if you do, delete them. This will fix this bug. After you delete them, run the MCreator again.