1.9.1 Mac Fullscreen Bug

Started by sephbeck1 on Sun, 09/22/2019 - 18:14

Topic category: Bugs and solutions

Last seen on 07:58, 13. Apr 2020
Joined May 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
1.9.1 Mac Fullscreen Bug
Sun, 09/22/2019 - 18:14

In Mcreator 1.9.0 I was running into an issue when running fullscreen mode in game my mouse position would not line up with the in game cursor, but it only happened a few times. However after updating to 1.9.1 The bug exists without fullscreen mode on, every time. When I turned Fullscreen mode on in the in game settings, the GUI completely bugged out, only appearing in the bottom left corner of the screen, but my cursor acts as if the GUI is taking up the whole screen. I can still access the menus however, but attempting to turn off Fullscreen crashes the gradle every time. Im now stuck where the game goes into fullscreen every time I load, and the bug happens every time. I'm gonna provide a screen recorded video soon to give a better understanding

Last seen on 01:10, 19. May 2020
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Thats a MC bug, not Mcreator…
Mon, 09/23/2019 - 04:38

Thats a MC bug, not Mcreator, just disable fullscreen before you do that, the gradle thing is def a MCreator one, but im saying the GUI being bugged is Minecraft.

Last seen on 07:58, 13. Apr 2020
Joined May 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
The game opens up in…
Mon, 09/23/2019 - 13:11

The game opens up in fullscreen by default since I turned Fullscreen on, how could I turn fullscreen off without opening the game, or is there a way I can reinstall my source gradle

Last seen on 01:10, 19. May 2020
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Go to the settings and click…
Mon, 09/23/2019 - 13:42

Go to the settings and click "Fullscreen: On" and it will crash your game most likely, but it shouldnt start in fullscreen

Last seen on 00:58, 28. May 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
F11 is fullscreen toggle
Mon, 09/23/2019 - 13:44

F11 is fullscreen toggle

Last seen on 01:10, 19. May 2020
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Entropy, they know this,…
Mon, 09/23/2019 - 13:46

Entropy, they know this, they mean to toggle it on startup, not after its already started.

Last seen on 07:58, 13. Apr 2020
Joined May 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
In the video I attempt to…
Mon, 09/23/2019 - 13:48

In the video I attempt to turn fullscreen off by pressing the button in game, but the game crashes, and continues to run in fullscreen next time despite me pressing the button. I actually forgot F11 toggle fullscreen though, but I tested it and it crashes the game as well, no luck.

Last seen on 00:58, 28. May 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Run it without the using the…
Mon, 09/23/2019 - 13:50

Run it without the using the IDE

Last seen on 00:58, 28. May 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Then fix the fullscreen and…
Mon, 09/23/2019 - 13:51

Then fix the fullscreen and try running it again in ide

Last seen on 00:58, 28. May 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
If that doesn't work..try…
Mon, 09/23/2019 - 14:17

If that doesn't work..try the options.txt file set fullscreen false

Last seen on 01:10, 19. May 2020
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
(You can find your …
Mon, 09/23/2019 - 14:44

(You can find your .minecraft folder for mcreator, where this is found, under

(Your username)/MCreatorWorkspace(s?)/(Workspacename)/run

this will be your .minecraft for the mcreator workspace)

Last seen on 07:58, 13. Apr 2020
Joined May 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Thanks both of you, I was…
Mon, 09/23/2019 - 16:25

Thanks both of you, I was able to go into options.txt and turn off full screen, but the bug still persists when its turned back on, so staying in windowed is a temporary solution