3D JSON item models with Mobs (FIXED)

Started by BlueAwesomeDinosaur on Sat, 10/05/2019 - 02:21

Topic category: Help with MCreator modding

Last seen on 00:13, 23. Oct 2019
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
3D JSON item models with Mobs (FIXED)
Sun, 10/06/2019 - 03:00 (edited)

I recently tried to give a mob a ranged weapon that had a 3D JSON model. The issue was that the item just appeared to be a bow. I do not know if this is a bug or not, so I put it into the "Help with MCreator modding" section.

Edited by BlueAwesomeDinosaur on Sun, 10/06/2019 - 03:00
There is no way custom…
Sat, 10/05/2019 - 21:06

There is no way custom ranged item would just appear to look like bow.

Last seen on 00:13, 23. Oct 2019
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
That's strange. It is doing…
Sun, 10/06/2019 - 00:45

That's strange. It is doing that for me. It only appears that way when a mob is holding it though. Custom models for tools/weapons and items work, but, at least for me. I was able to fix it by giving it an item with the same model. I have no idea why the ranged item appears as a bow when it is held by a mob. At least I found a way around it.

Last seen on 00:13, 23. Oct 2019
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
It seems to be an issue with…
Sun, 10/06/2019 - 02:39

It seems to be an issue with the mob or item because I have not had any issues with other ranged mobs/weapons before like this.

Last seen on 00:13, 23. Oct 2019
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I figured out the issue. It…
Sun, 10/06/2019 - 02:50

I figured out the issue. It was an odd issue with the mob. Once I changed the item and changed it back, it was as it should be. Thanks for the help anyways. I will report if I have anymore issues with the mob. As a final note, I think it was caused when I modified the code of the mob to change its ranged damage because that was the only thing that the only thing that made it somewhat different from my other elements. It could prevent further issues like this if there was a way to change the ranged damage and/or the ranged power of a mob. Again, thank you for the help, and I am sorry for having to ask about this easily fixed bug. Have a great rest of your day!

Last seen on 00:13, 23. Oct 2019
Joined Aug 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Sorry, I accidentally…
Sun, 10/06/2019 - 02:59

Sorry, I accidentally repeated "the only thing that" it my response.