[FIXED] Custom helmet model not rendering

Started by Den44x on Tue, 07/07/2020 - 14:01

Topic category: Help with MCreator software

Last seen on 03:39, 6. Oct 2020
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[FIXED] Custom helmet model not rendering
Wed, 07/08/2020 - 16:31 (edited)

Hello there, I made a 3d armor model, loaded it in mcreator , fixed arms animations and everything looked fine until I put the helmet on ...

It looks like this in game

 

 

Original Model

 

 

Any idea what caused this?

I believe arms looked something like that before I fixed the animation, is that the problem?

Edited by Den44x on Wed, 07/08/2020 - 16:31
Last seen on 21:36, 16. Jun 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
How did you fix it?
Wed, 07/08/2020 - 16:56

How did you fix it?

Last seen on 03:39, 6. Oct 2020
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It was all about textures, I…
Wed, 07/08/2020 - 20:32

It was all about textures, I painted the helmet layer when It should've been empty. There are texture parts that should be avoided.

Last seen on 04:14, 1. Nov 2020
Joined Feb 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Could you elaborate on this?…
Mon, 10/05/2020 - 03:19

Could you elaborate on this? I'm having the exact same problem.

Last seen on 03:39, 6. Oct 2020
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
That's how your texture is…
Mon, 10/05/2020 - 04:40

Texture

That's how your texture is supposed to look like, the avoid space is mostly for second layer, on custom objects you don't rly have that second layer, so if you paint over the wrong parts they will be shown incorrectly above your model 

Last seen on 03:39, 6. Oct 2020
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
http://imgur.com/a/EUPwNsM…
Mon, 10/05/2020 - 04:47

http://imgur.com/a/EUPwNsM

In case it doesn't work in the post above 

Last seen on 04:14, 1. Nov 2020
Joined Feb 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Thanks, i was painting all…
Tue, 10/06/2020 - 02:51

Thanks, i was painting all over that Avoid Area, I'll give this a try today.