Broken workspace

Started by DrKraken on Fri, 09/04/2020 - 09:24

Topic category: Help with MCreator software

Last seen on 13:34, 10. Oct 2020
Joined May 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Broken workspace
Fri, 09/04/2020 - 09:24

My workspace is not working properly, it doesn't look to be something too bad, i think someone who knows about coding could easily fix it, but well its not really my case.

So this is basically a post specifically for a dev, to help me with the workspace. The problem is that any dimension i try to make comes out with an error, it doesn't matter what I do, every single dimension i create comes out with an error. A model of a lamp I made is not being added to the game, it just doesnt appear, no matter what i do, it could be the model, but i have no clue exactly what it is, so if a dev could check this out for me i would love it, overall, the workspace has numerous bugs, but these are the most noticeable ones.

I could take the time to make the workspace once again, but that would take me HOURS and HOURS. So before taking that option in count, i want to see if i can find a solution for this, thanks in advance, and here is the link for the mod workspace in a ZIP file:  

PD: I know that the error with the lamp is not the lamp model, because i tried the same configurations with the same model and texture on an empty workspace and it worked 100%, so its definitely my corrupted workspace.

LINK: https://drive.google.com/file/d/1D1ES7ULy2a7dmtQfTEKX-yimjdNLfR_8/view?…

Last seen on 19:03, 24. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Delete the entire <your user…
Fri, 09/04/2020 - 10:43

Delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.

Also how about some search?

https://mcreator.net/search/content?keys=dimensions+not+working -> First result -> https://mcreator.net/forum/62865/dimensions-not-working-114

Last seen on 13:34, 10. Oct 2020
Joined May 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Yes, i searched for this…
Sat, 09/05/2020 - 09:57

Yes, i searched for this before, tried all the solutions that were provided to me, and the workspace is still broken, that why i had to start a post about it, so someone who knows about coding can check it out.