Making mods for older Minecraft versions

Started by StanchVirus011 on Sun, 09/27/2020 - 23:56

Topic category: Help with MCreator software

Last seen on 05:24, 21. Oct 2020
Joined Oct 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Making mods for older Minecraft versions
Sun, 09/27/2020 - 23:56

I've noticed that in MCreator 2020.4 you can only choose between two Minecraft versions, 1.14.- and 1.15.-

If I wanted to make mods for older versions would I have to install an older MCreator or is there another way to do this?

Thanks.

Last seen on 21:45, 26. Oct 2020
Joined Jun 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
There is a point where it's…
Mon, 09/28/2020 - 08:11

There is a point where it's useless because the recent versions have brought too much new stuff to MCreator and older versions are not compatible with the new features. There is also a point where Forge servers can't provide the files needed to MCreator.
The oldest "safe" version to use is the 1.12.2 which can be use with a plugin but all new stuff brought with MCreator 2020.4 and 2020.5 are useless with this.