Custom generator not working

Started by FireWorks_CreepeR on Sun, 11/29/2020 - 12:43

Topic category: Help with modding (Java Edition)

Last seen on 12:43, 7. Jan 2021
Joined Jun 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Custom generator not working
Sun, 11/29/2020 - 12:43

I was making a block for my mod which was supposed to generate energy basing the fuel power of items in the inventory. Anyways, instead of "burning" the items the block instantly goes back to the "off-mode". I guess the procedure blocks themselves might be bugged, but I'm not sure.
 

The elements of the Coal Generator are CoalGenerator, CoalGeneratorWorking, ProcCoalGeneratorActivate and ProcCoalGeneratorWork.

Details:

  • MCreator version: 2020.5
  • Generator type: Forge 1.15.2
  • OS: Windows 10
Last seen on 12:43, 7. Jan 2021
Joined Jun 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I was using procedure blocks…
Sun, 11/29/2020 - 12:47

I was using procedure blocks with local variables. Checking the number to change between the active and inactive mode, increasing the number to the fuel power of the item and subtraction from the number variable for "burning" of items.

Last seen on 08:26, 19. Jan 2021
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Local variables are not…
Mon, 11/30/2020 - 09:06

Local variables are not preserved and only exist when the procedure is run once.

Last seen on 12:43, 7. Jan 2021
Joined Jun 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
@Klemen What should I use…
Tue, 12/01/2020 - 09:52

@Klemen What should I use instead?