[2020.6 snapshot] Custom dimension portal not working & other issues

Started by FireBlox on Fri, 12/25/2020 - 21:53

Topic category: Help with MCreator software

Last seen on 12:26, 24. May 2022
Joined Jul 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[2020.6 snapshot] Custom dimension portal not working & other issues
Fri, 12/25/2020 - 21:53

I've finally decided to play around with MCreator for a version other than 1.12.2 and recently started doing stuff in the new snapshot for 1.16.4. Things seem to be going quite well, but I have ran into a few problems:

First off, I was trying to make a snowy biome, but no matter what I did I couldn't get the biome to naturally have snow on the ground. I might be missing something, in which case I would like to know what I am doing wrong, but if not, then this should be looked into. On a more positive note about biomes though, I really like that you can now specify the shape of custom trees through the biome editor, and would perhaps be willing to contribute some template tree styles if that is at all a possibility.

The other thing I noticed is that I can't seem to get custom dimension portals to work. I only tried this once, so I'll try making another custom dimension to see if that gives different results, but as far as I know, the portals don't work. I can walk through it, but it doesn't do anything at all.

These are the only issues I've really ran into thus far, but I'll make sure to say something if anything else comes up. The new snapshot works pretty well as far as I can tell, and I might actually continue to use this software to develop my mod once I have the proper time to commit to actually making progress and not just messing around with seemingly random things.

Snowy is just temperature…
Sat, 12/26/2020 - 10:53

Snowy is just temperature property, it will not make it actually snowy.

The other thing I noticed is that I can't seem to get custom dimension portals to work. I only tried this once, so I'll try making another custom dimension to see if that gives different results, but as far as I know, the portals don't work. I can walk through it, but it doesn't do anything at all.

Please report the bugs in the appropriate place here: https://github.com/MCreator/MCreator/issues Make sure to respect the bug report template, include minimal reproducible workspace, and split each issue you find in a separate ticket.

Last seen on 12:26, 24. May 2022
Joined Jul 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I've figured out the real…
Wed, 12/30/2020 - 03:00

I've figured out the real problem with the portal: I got it to work when I changed the biome used for the dimension to the [still not so snowy] biome I mentioned earlier. It turns out that, at least for me, custom dimensions fail to load if their biome is flagged as unable to spawn in the overworld. 

As for the custom biome, I know that Snowy is just a biome dictionary tag. I made a snowy biome in my mod Chaotica for 1.12.2 just fine, and even when I set this new biome to the proper temperature, the biome does not spawn with snow on the ground. If there is a way, I would like to know how to fix this.