Procedures seem to refuse to work despite all reason

Started by EeveeSinclair on Thu, 01/14/2021 - 03:49

Topic category: Bugs and solutions

Last seen on 16:17, 21. Jan 2021
Joined Jan 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Procedures seem to refuse to work despite all reason
Thu, 01/14/2021 - 03:49

So, I made a trick weapons mod with elements such as a sword that turns into a musket, and a parasol gun that can be opened and gives the player slow falling!

I wrote a few procedures and play-tested them to make sure they work, even across multiple workspaces, and got it all sorted out, and over time moved on to other elements.

But then, for no apparent reason whatsoever, the procedures decided to stop working! The musket won't turn back into the sword, despite the only procedure blocks being to set the sword in your hand and remove the musket, and the parasol stays closed, despite its right-click procedure telling it to replace the items like with the weapon previous.

I know it can't be a procedure issue, because I saw it work with my own eyes before. I tried searching across this knowledge base for answers, and haven't found much help, unfortunately, which inclined me to write this!

I know from some testing that it isn't:
-A workspace-specific issue
-A firewall issue
-An internet issue
-A virus issue
-A Cache issue
-A procedure issue (99% sure :P)

I did my best to triple check this post is the first of its kind, so I apologize if I turn out to be wrong on that.

If anyone's has a similar issue and/or knows how to fix stuff like this, please send a reply my way!

(By the way, using 2020.5)

Last seen on 12:23, 25. Jan 2021
Joined Nov 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Did you check you actually…
Thu, 01/14/2021 - 09:05

Did you check you actually linked the procedure to the item?

Last seen on 16:17, 21. Jan 2021
Joined Jan 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I did! By all means, they…
Thu, 01/14/2021 - 19:16

I did! By all means, they should work.

Last seen on 16:17, 21. Jan 2021
Joined Jan 2021
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
A little embarrassed, but I…
Sat, 01/16/2021 - 21:22

A little embarrassed, but I managed to fix it!

I had set the non-sword weapons to items and given them certain properties to make them impersonate weapons, but their use duration was at 1 like a normal sword, which apparently caused the issue. I turned it back to 0, and the items work like a charm!