MCreator not opening after closed with Task Manager

Started by LercDsgn3 on Mon, 02/01/2021 - 08:29

Topic category: Help with MCreator software

Last seen on 21:47, 1. Jan 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
MCreator not opening after closed with Task Manager
Mon, 02/01/2021 - 08:29

So I wanted to make a workspace with the new snapshot, but accidentally used 2020.5, well, I tried to close it but it didn't work. Then I used the task manager. It did work, but since it was somewhat a force-quit, it may have caused some errors. The weird thing here is, 2020.5 still opens, 2021.1 snapshot doesn't. It may be a problem about the snapshot but I don't think so. I think I shouldn't have closed the program like that, it probably corrupted the files. 

 

The error message is here.

Is there any way I can fix it?

When you open MCreator, it…
Mon, 02/01/2021 - 09:47

When you open MCreator, it is in the middle of an important setup and thus disables closing. If you close it by force, you will break things.

Try re-downloading 2021.1 and try running it with bat file to see if it makes a difference.

It could also be your AV interfering

Last seen on 21:47, 1. Jan 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Thanks, I re-downloaded it…
Mon, 02/01/2021 - 13:51

Thanks, I re-downloaded it as you told, and it seems to be working. The .bat file, however, opens a window -like it does in the .exe- but instantly closes it. The .exe one works in the zip, but not out, like perhaps in desktop. It gives the same error there. One more thing, I had made a workspace (before the last one which caused all of this to happen) and it still stays and works perfectly fine. Plus, when I went to McreatorWorkspaces > the broken workspace and open the .mcreator file, it re-ran the setup and succesfully completed it. There was missing folders which are in the other created workspaces but not in this one, I guess it detects what is not there and creates only those. Because the setup was pretty quick. I appreciate MCreator, it even fixes what I have broken :)